Gerer sa propre extension

Résolu
Signaler
Messages postés
438
Date d'inscription
samedi 24 mai 2003
Statut
Membre
Dernière intervention
23 janvier 2011
-
Messages postés
438
Date d'inscription
samedi 24 mai 2003
Statut
Membre
Dernière intervention
23 janvier 2011
-
Bonjour à tous,

j'ai suivi le tuto de Cyril : http://www.aspfr.com/codes/HANDLER-COMMENT-GERER-PROPRE-EXTENSION-TUTOS-ASP-NET_29118.aspx

je le test sous VS sur mon pc, aucun souci, sa marche bel et bien. Mais quand je transfert sur mon serveur qui est sous windows 2003 sa ne marche pas. il ne fait pas appel à la class Utilities

Alors j'ai tenter de faire la 2eme méthode qu'il explique lorsque l'on n'à pas accès à IIS, en rajoutant l'extension .ashx

et sa ne fait toujours appel à cette fameuse class ! J'ai regarder la configuration du site dans les propriétés mais je ne vois pas d'option qui me saute au yeux.

Y'a t-il une option à activé ? Pourquoi sous VS sa marcherai et non sous le serveur !

Si quelqu'un à une idée

Merci

2 réponses

Messages postés
438
Date d'inscription
samedi 24 mai 2003
Statut
Membre
Dernière intervention
23 janvier 2011
1
bon lol

le problème est résolu.

J'avais mis un msgbox au début de la class, ce qui me permettais de voir si la class était bien appelée. C'est tout simplement cette petite ligne de code qui genait ....
Messages postés
438
Date d'inscription
samedi 24 mai 2003
Statut
Membre
Dernière intervention
23 janvier 2011
1
bon j'ai du nouveau, quand j'appel directement le fichier en faisant appel à la class (donc avec l'extension ashx) il m'affiche ce message :

L'affichage d'une boîte de dialogue modale ou d'un formulaire lorsque l'application ne s'exécute pas en mode UserInteractive n'est pas une opération valide. Spécifiez le style ServiceNotification ou DefaultDesktopOnly pour afficher une notification à partir d'une application de service.

Avec un message comme ca ! je me dis en faisant une recherche sur google je vais forcément trouver ma réponse ! et bien non :( j'ai fouiner dans IIS voyant si il n'y avait pas quelque chose à cocher pour activer ce mode UserInteractive et je n'ai rien trouver :(

je continue mes recherches, si quelqu'un à déjà entendu parler de ce mode ;)