Exe généré avec Delphi et accés à base Access via KaDao

Signaler
Messages postés
1
Date d'inscription
jeudi 3 février 2005
Statut
Membre
Dernière intervention
25 mars 2008
-
Messages postés
2
Date d'inscription
samedi 1 mars 2003
Statut
Membre
Dernière intervention
10 avril 2009
-
Bonjour,

j'ai écrit un programme DELPHI qui accède à une base de données ACCESS via les composants KaDao.
Sur mon PC Développeur tout baigne.
Par contre, je souhaiterai que ce programme puisse tourner sur un PC ou Delphi n'est pas installé.
J'ai donc fait une copie du .exe que j'ai collé sur mon PC Utilisateur.
Lorsque j'essaie de le lancer, il ne se passe RIEN! le sablier s'affiche quelques secondes puis rien. Aucun message et ma fenêtre d'accueil ne s'affiche pas.
NB:
- j'ai fait la même chose avec un pgm Delphi affichant une simple fenêtre d'accueil (sans aucun accès à une base de données) et là, bien sûr, ça fonctionne.
- j'ai prévu une procédure de vérification de  présence de ma base Access avant de l'ouvrir. Sur mon PC Développeur le contrôle est bien déclenché lorsque la base n'est pas trouvée, sur mon PC Utilisateur il ne se passe RIEN!
- je n'ai que le run-time d'Access d'installé sur mon PC utilisateur. A tout hasard, j'ai installé le pac MDAC_TYP pour (être sûr d')avoir les composants d'accès aux données microsoft sur mon PC Utilisateur.

Quelqu'un a-t-il une piste pour m'aider à régler mon problème?

merci

1 réponse

Messages postés
2
Date d'inscription
samedi 1 mars 2003
Statut
Membre
Dernière intervention
10 avril 2009

Bonjour,

Vous devrez installer ou mettre à jour les composants logiciels MDAC (Microsoft Data Access Componant) ainsi que le Jet Engine et ce, sur les postes devant manipuler votre base Access.
Pour les versions de Windows (2k/Xp/2003) disposant de "Microsoft Update" les mises à jour de ces composants se font automatiquement.
Ces composants sont disponibles au téléchargement sur le site de Microsoft