Référence Ax

Signaler
Messages postés
438
Date d'inscription
samedi 24 mai 2003
Statut
Membre
Dernière intervention
23 janvier 2011
-
Messages postés
438
Date d'inscription
samedi 24 mai 2003
Statut
Membre
Dernière intervention
23 janvier 2011
-
Bonjour à tous,

C'est un problème sans être un problème...

Mon projet web étant à l'origine basé sur le Framework 2.0 j'ai mis à jour les références qui en avait besoin pour l'utilisation d'Ajax. Le site fonctionne, il n'y à pas de souci, mais quand je fais générer la solution, dans le fichier web.config il me rajoute automatiquement ces références :

<

addassembly="
System.Web.Extensions, Version=1.0.61025.0<

addassembly="
System.Web.Extensions.Design, Version=1.0.61025.0
Et les objets Ajax ne marche plus en m'affichant ce type d'erreur par exemple :

Une référence indirecte est établie à l'assembly System.Web.Extensions version 3.5.0.0, qui contient 'AjaxControlToolkit.ModalPopupExtender'. Ce projet fait référence à une version antérieure de System.Web.Extensions version 1.0.61025.0. Pour utiliser 'AjaxControlToolkit.ModalPopupExtender', vous devez remplacer la référence à System.Web.Extensions par la version 3.5.0.0 ou ultérieure

Si j'efface manuellement ces lignes, le projet refonctionne.

J'ai bien entendu ces références qui sont déjà présente dans le fichier web.config mais en 3.5.0.0 !
Alors pourquoi me rajoute t'il automatiquement celle ci ?

si quelqu'un à un idée, merci par avance

2 réponses

Messages postés
5
Date d'inscription
jeudi 13 juin 2002
Statut
Membre
Dernière intervention
17 novembre 2009

Bonjour j'ai le même problème si tu as trouvé la solution peux-tu me l'indiquer ?
RISQ@telefonica.net
Messages postés
438
Date d'inscription
samedi 24 mai 2003
Statut
Membre
Dernière intervention
23 janvier 2011

Salut,

Oui sa été réparé. Après je ne sais vraiment plus comment j'ai fait ! Mise à jour ? Remplacement de version plus récente de fichier dll ? Mise à jour Framework ?

Bref ce projet j'ai beau le générer une nouvelle fois, l'erreur à disparu.
tu es sous quel Framework ?