Problème avec Access

Signaler
Messages postés
2
Date d'inscription
jeudi 13 mars 2008
Statut
Membre
Dernière intervention
15 mars 2008
-
Messages postés
2
Date d'inscription
jeudi 13 mars 2008
Statut
Membre
Dernière intervention
15 mars 2008
-
Bonjour à tous,
Je suis désolée, je suis nouvelle sur ce site et je ne suis pas sûre que je pose ma question au bon endroit.
Voilà, j'ai un problème avec le logiciel Access. Je suis en train de créer une base de données et j'ai voulu créer une macro et c'est là que les problèmes ont commencé. Tout d'abord, j'ai eu un message d'erreur comme quoi il n'y avait pas suffisamment de mémoire pour éxecuter l'action. J'ai fini par supprimer la macro.
C'est là que tout a bugué : maintenant, à chaque fois que j'essaie d'ouvrir ma base de données (formulaire, requête, ...) j'ai un message d'erreur comme quoi Access a rencontré un problème et va devoir fermer. Résultat : ma base de données est inutilisable, je ne peux absolument rien faire !!!!
Merci d'avance pour votre aide, c'est un projet que je dois rendre et si je ne trouve pas de solutions, je vais devoir tout recommencer (Sniffff !!!!! )
Chloé

2 réponses

Messages postés
4822
Date d'inscription
lundi 11 novembre 2002
Statut
Membre
Dernière intervention
15 novembre 2016
13
Salut,

Je soupçone que ta macro devait se lancer plusieurs fois ou et il y a sûrement quelque chose qui rempli la mémoire jusqu'à saturation...faudrait voir le code de la macro et le code de connection et requête à ta bdd, pour que les membres puissent te répondre avec précision...

A+
Exploreur

 Linux a un noyau, Windows un pépin

Un jeu en flash sympa...? Voir ici
Si vous voulez vous inscrire
mettez c
Messages postés
2
Date d'inscription
jeudi 13 mars 2008
Statut
Membre
Dernière intervention
15 mars 2008

Salut,

Merci d'essayer de m'aider. A priori, ma macro n'apparaît plus dans le menu de départ d'access. Mais je sais pas comment savoir s'il en reste une trace. Par contre, j'ai quelques formulaires qui démarrent sans problème. Mais si j'essaie la moindre action (genre supprimer un objet ou un formulaire), ça bugue de nouveau et access ferme. J'ai regardé le rapport d'erreur, apparement les fichier concernés sont des fichiers Temp. Je les ai tous supprimer mais ça n'a pas vraiment eu d'effet (légère amélioration mais bon...) A signaler, j'ai téléchargé anybouton et celui ci (lorsque je lance le .ocx du zip) me dit que le programme a bien été installé dans un fichier Temp. Ya peut être un rapport???!!!


 Merci pour vos futurs commentaires.


Chlo