Probleme avec fsockopen et certains serveurs php

Signaler
Messages postés
261
Date d'inscription
vendredi 4 mars 2005
Statut
Membre
Dernière intervention
27 septembre 2008
-
Messages postés
1980
Date d'inscription
dimanche 20 février 2005
Statut
Membre
Dernière intervention
24 septembre 2012
-
Bonjour,

Voila j'ai un script qui fait un fsockopen d'une page qui affiche "coucou", mais quand je reçois les données et que je les affiche, j'obitent "6 coucou 0" et non "coucou".
Savez vous d'ou peut venir ce problème ?

Merci de vos réponses.

3 réponses

Messages postés
12303
Date d'inscription
mardi 10 février 2004
Statut
Modérateur
Dernière intervention
30 juillet 2012
39
faudrait voir ton script...

/**
* @author coucou747 <coucou747@hotmail.com>
* @see irc://cominweb.uni-irc.net/#programmation
*/
Messages postés
261
Date d'inscription
vendredi 4 mars 2005
Statut
Membre
Dernière intervention
27 septembre 2008

je pense pas que ça vienne de la vu que sur certain serveur j'ai pas ce probleme.

Voila mon code

  [mailto:$h=@fsockopen($domain,80,$errno,$errstr,8 $h=@fsockopen($domain,80,$errno,$errstr,8]);
  if ($h)
  {
   $out = "POST /".$chemin." HTTP/1.1\r\n";
      $out .= "Host: ".$domain."\r\n";
      $out .= "Connection: Close\r\n";
   $out .= "Content-type: application/x-www-form-urlencoded\r\n";
   $out .= "Content-Length: ".strlen($postdata)."\r\n\r\n";
   $out .= $postdata."\r\n";
   fwrite($h,$out);
   while (!feof($h))
   {
    $data.=fgets($h,256);
   }
  fclose($h);
  }
Messages postés
1980
Date d'inscription
dimanche 20 février 2005
Statut
Membre
Dernière intervention
24 septembre 2012
5
Hello,

Je ne connais pas la réponse, mais ce n'est pas toi qui posait la question l'autre jour, et qui disait que c'était la longueur de quelques chose ?
si ce n'est pas toi, regarde dans les messages un peu plus anciens, ça t'aidera peut-être.
à+