Pb mise en place du code

fanatikx
Messages postés
46
Date d'inscription
mardi 17 janvier 2006
Statut
Membre
Dernière intervention
4 juin 2010
- 20 févr. 2008 à 18:07
fanatikx
Messages postés
46
Date d'inscription
mardi 17 janvier 2006
Statut
Membre
Dernière intervention
4 juin 2010
- 20 févr. 2008 à 19:39
Bonjour,
Voici la situation:
j'ai sur _root 2 calques, un nommé "menu" (sur lequel est placé le clip du même nom) et un calque action.
Mon clip menu est constitué d'une forme graphique (le conteneur en sorte) et de boutons (le contenu).
Dans ce même clip, de la frame 1 à 15, ma forme graphique initialement à _alpha 0 se montre peu à peu pour finalement être complêtement noir à la frame 15. Sur celle ci apparait alors mes boutons.

Voila, j'aimerais, de _root, à partir d'un code actionscript donner l'utilité des boutons situés dans le clip menu. Mais impossible de le faire...voici le code que j'ai placé dans le calque action sur _root en prenant l'exemple sur 1 seul bouton que je vais nommer btn_contenu et qui devrait ramener mon clip à sa frame 1:

menu.btn_contenu.onRelease=function()
{
 menu.gotoAndStop(1);
}

Bien entendu, les noms d'occurences correspondent dans mon clip. Le probleme c'est que puisque mon bouton est sur la frame 15 de mon clip (et non sur la 1), bha il ne marche pas. probleme de tete de lecture ???

J'aimerais beaucoup avoir de l'aide

merci d'avance!!

BhaaL

2 réponses

docodoc
Messages postés
1671
Date d'inscription
dimanche 6 mars 2005
Statut
Membre
Dernière intervention
21 juillet 2013
4
20 févr. 2008 à 18:42
salut

ton codage est correct ... mais ton btn_contenu doit etre present dans la premiere frame du clip menu
tu pourrais bidouiller un _alpha du bouton en meme temps que celui de "conteneur" et ca fonctionnerait
mais le plus simple est de mettre ton codage directement dans la timeline des clips

ca t'aide ??
a+
0
fanatikx
Messages postés
46
Date d'inscription
mardi 17 janvier 2006
Statut
Membre
Dernière intervention
4 juin 2010

20 févr. 2008 à 19:39
Merci d'avoir répondu si vite.

Le probleme c'est que j'aimerai que l'ensemble du code de mon site soit sur un calque et qui plus est sur une même frame. Parce que dans ma version V1 du site j'ai fait, j'ai suivi la méthode tu me proposes, cad dire mettre mon code dans la time line de mes clips. Mais j'avais beaucoup de clip donc beaucoup de timeline et je trouvais ca un peu long de devoir trifouiller mon clip pour trouver le bout de code qui m'intéressait. Alors je me suis dit de tout avoir sur une frame et une seule serait un gain de temps monstrueux.

Ta solution du _alpha sur les boutons est une possiblité mais ce n'est pas très propre, tu me diras je ne suis plus à ca prêt!

Merci de ta réponse en tout cas!

BhaaL
0