Connéxion PHP ORACLE9i [Résolu]

rhabib 99 Messages postés dimanche 25 janvier 2004Date d'inscription 22 février 2008 Dernière intervention - 20 févr. 2008 à 09:36 - Dernière réponse : magicientarik 41 Messages postés lundi 10 septembre 2007Date d'inscription 13 avril 2011 Dernière intervention
- 26 avril 2010 à 17:54
Salut,
depuis un moi j'assaie de me connecter a oracle via php mais rien ne se passe,des fois la page est vide , des j'ai le message undefined function et des fois c'est une erreur ora.xxxxxx
est ce que quelqu'un pourrais me dire comment :
1-configurer un environnement WINXP SP2 pour pouvoir ce connecter
2-comment ce connecter a oracle via php

ps:
- oracle server 9i installer
- easyphp 1.8 installer
- les deux fonctionnent bien

merci.
RHABIB
Afficher la suite 

Votre réponse

5 réponses

Meilleure réponse
cs_hakiman 24 Messages postés lundi 14 mai 2007Date d'inscription 26 mai 2008 Dernière intervention - 20 févr. 2008 à 11:54
3
Merci
tu peux utiliser ce lien pour plus des information
http://www.commentcamarche.net/faq/sujet-123-connexion-a-une-base-oracle-en-php
si ça marche pas tu peux m'envoyer ton hotmail pour t'envoyer
le fichier car j'ai déja fait un projet en PHP et oracle

Merci cs_hakiman 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 95 internautes ce mois-ci

Commenter la réponse de cs_hakiman
rhabib 99 Messages postés dimanche 25 janvier 2004Date d'inscription 22 février 2008 Dernière intervention - 21 févr. 2008 à 09:38
0
Merci
ok merci je vais voir tout de suite .

RHABIB
Commenter la réponse de rhabib
rhabib 99 Messages postés dimanche 25 janvier 2004Date d'inscription 22 février 2008 Dernière intervention - 22 févr. 2008 à 17:05
0
Merci
ok c'est bon j'ai reussi ca marche merci a hakiman

RHABIB
Commenter la réponse de rhabib
cs_hakiman 24 Messages postés lundi 14 mai 2007Date d'inscription 26 mai 2008 Dernière intervention - 22 févr. 2008 à 18:36
0
Merci
pas de quoi rhabib je suis à votre service
Commenter la réponse de cs_hakiman
magicientarik 41 Messages postés lundi 10 septembre 2007Date d'inscription 13 avril 2011 Dernière intervention - 26 avril 2010 à 17:54
0
Merci
Bonjour,
SVP, j'ai un grand problème qui me bloque ça fait plus que trois semaine.
J'arrive pas à connecté une application php à une base Oracle, j'ai fait bcp de recherche sur les forum mais toujours j'arrive pas.
Ma base de Données est installé sur un serveur unix distant, et je travail sur une machine windows, j'ai installé EasyPHP, et l'instance Client Oracle 10g.
L'extention PCI8 est décommenté du fichier php.ini et c'est prise dans phpinfo().
j'essaye de me connecter via le code suivant :

$conn = oci_connect('USER', 'PWD', 'Adresse_BDD/service_name');
if (!$conn) {
$e = oci_error();
trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}
lorsque je lance ma page php j'obtiens l'erreur suivant :

Warning: oci_connect() [function.oci-connect]: ORA-12514: TNS : le processus d'ecoute ne connait pas actuellement le service demandé dans le descripteur de connexion.

Fatal error: ORA-12514: TNS : le processus d'écoute ne connaît pas actuellement le service demandé dans le descripteur de connexion.
SVP est ce que quelqu'un a une idée de ce problème.

Une autre information c'est que j'arrive à me connecter à la base via sqlplus on utilisant le tnsnames.ora qui existe dans C:\orant\net80\Admin de forms6i

SVP est ce que quelqu'un peut m'aider pour que je puisse avancer.

D'avance un grand Merci
Commenter la réponse de magicientarik

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.