Cookie firefox OK mais pas internet explorer

Résolu
spaceyogourt Messages postés 19 Date d'inscription lundi 14 mars 2005 Statut Membre Dernière intervention 18 juillet 2008 - 17 févr. 2008 à 16:08
spaceyogourt Messages postés 19 Date d'inscription lundi 14 mars 2005 Statut Membre Dernière intervention 18 juillet 2008 - 18 févr. 2008 à 16:58
Bonjour à tous
Je fais appel à vous car je bloque sur un problème de cookie...
j'utilise un cookie pour enregistrer le fait qu'un visiteur puisse accéder à son espace client grace à son pseudo

setcookie ("pseudo", $client_infos['pseudo'], time()+$boutique->duree_cookie_client, '/');

sous firefox, pas de soucis, le cookie s'enregistre bien mais sous internet explorer, rien à faire, le cookie ne veux pas s'enregistrer

Merci d'avance pour vos réponses

2 réponses

sbool Messages postés 115 Date d'inscription mercredi 27 août 2003 Statut Membre Dernière intervention 7 mars 2008
18 févr. 2008 à 03:59
Yep, j'ai eu le meme probleme et j'ai mis time dans une session, puis au lieu de verifier si la variable existe, on teste sa valeur:
vrai time = time_maintenant - ancien_time
 depuis, plus de probleme...
spaceyogourt Messages postés 19 Date d'inscription lundi 14 mars 2005 Statut Membre Dernière intervention 18 juillet 2008
18 févr. 2008 à 16:58
merci pour la réponse
je viens de tester en passant par une variable mais ca n'a pas marché,
par contre, tu m'a mis la puce à l'oreille par rapport à l'heure....
mon serveur apache etait encore en l'an 2005.....
j'ai mis l'horloge à jour et maitenant c'est nikel
après, à savoir pourquoi ca marchait sur firefox et pas sur IE, aucune idée mais merci encore
Rejoignez-nous