Firebird Embedded sur un Windows XP Embedded : DLL no found [Résolu]

Signaler
Messages postés
129
Date d'inscription
lundi 17 mars 2003
Statut
Membre
Dernière intervention
4 mars 2010
-
Messages postés
129
Date d'inscription
lundi 17 mars 2003
Statut
Membre
Dernière intervention
4 mars 2010
-

3 réponses

Messages postés
14008
Date d'inscription
samedi 29 décembre 2001
Statut
Modérateur
Dernière intervention
28 août 2015
70
Salut
D'après d'autres forums (trouvés simplement en tapant "fbembed 0x8007007E" dans un moteur de recherche), ils disent :
- que ce serait un défaut de fabrique qui pourrait se résoudre en installant la DLL nommée MSVCP71
- ou bien ces explications http://blog.vyvojar.cz/jirka/archive/2007/01/28/firebird-embedded-and-net.aspx
- ou d'essayer cette version fbClient 2.0.1 http://garr.dl.sourceforge.net/sourceforge/firebird/FirebirdClient-2.0.1.exe

Vala
Jack, MVP VB
NB : Je ne répondrai pas aux messages privés

<hr />Le savoir est la seule matière qui s'accroit quand on la partage (Socrate)
Messages postés
129
Date d'inscription
lundi 17 mars 2003
Statut
Membre
Dernière intervention
4 mars 2010

(sorry mais je crois que j'ai un bug là)

Bonjour,
Je travail actuellement sur un Windows XP Embedded (XPe pour les intimes). Sur mon ordinateur de développement (un XP traditionnel), il n'a aucun problème d'intéraction avec Firebird Embedded (en ADO.NET), j'ai mis les DLLs suivante dans le répertoire à coté de l'exécutable :

* fbembed.dll
* icudt30.dll
* icuin30.dll
* icuuc30.dll

j'ai fait exactement la même chose sur le XPe mais il me donne une erreur que voici : Unhandled exception has occured in you application (...) Unable to load DLL 'fbembed.dll : The specified module could not be found {Exception from HRESULT : 0x8007007E}

J'ai du coup tenté d'envoyé ces même DLLs dans le system32 mais sans plus de résultat.

Je suis perdu, avez-vous une idée ?

Merci d'avance,
Jean-Pierre Sneyers
Messages postés
129
Date d'inscription
lundi 17 mars 2003
Statut
Membre
Dernière intervention
4 mars 2010

Merci, il me manquait bien deux DLL: MSVCP71 et MSVCR71