Application serveur non disponible [Résolu]

yanis7518 283 Messages postés mercredi 7 décembre 2005Date d'inscription 9 juillet 2010 Dernière intervention - 4 févr. 2008 à 11:21 - Dernière réponse : yanis7518 283 Messages postés mercredi 7 décembre 2005Date d'inscription 9 juillet 2010 Dernière intervention
- 5 févr. 2008 à 09:11
Salut a tous voila j'ai developpé un site WEB asp.net avec des ajaxcontroltoolkit

Je suis sous XP pro SP2 et IIS 5.1

asp.net est enregistré sur IIS : aspnet_regiis.exe -i

j'ai essayé d'accédé a mon site et j'obtiens l'erreur suivante :
<hr />
Application serveur non disponible
L'application Web à laquelle vous essayez d'accéder sur ce serveur Web n'est pas disponible actuellement.  Cliquez sur le bouton "Actualiser" de votre navigateur Web pour renouveler la demande.

Remarque de l'administrateur : Un message d'erreur détaillant la cause de l'échec de cette demande spécifique peut être trouvé dans le journal des événements de l'application du serveur Web. Consultez cette entrée du journal pour connaître la cause de cette erreur.

<hr />dans l'observateur d'evenement j'obtiens l'erreur suivante :

<hr />
Type de l'événement : Erreur
Source de l'événement : ASP.NET 2.0.50727.0
Catégorie de l'événement : Aucun
ID de l'événement : 1334
Date :  04/02/2008
Heure :  10:51:40
Utilisateur : N/A
Ordinateur :  MONORDI
Description :
La description pour l'ID d'événement ( 1334 ) dans la source (ASP.NET 2.0.50727.0) est introuvable. L'ordinateur local n'a peut-être pas les informations de Registre ou les librairies requises pour afficher les messages émanant d'un ordinateur distant. Vous pourrez peut-être utiliser l'option /AUXSOURCE= pour récupérer cette description. Reportez-vous aux rubriques Aide et support pour plus de détails. Les informations suivantes font partie de l'événement : L'initialisation de AppDomain a échoué :/LM/W3SVC/1/RootException: System.IO.FileLoadException

Message: Impossible de charger le fichier ou l'assembly 'System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' ou une de ses dépendances. Accès refusé.

StackTrace:    à System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)
   à System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)
   à System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   à System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   à System.Activator.CreateInstance(String assemblyName, String typeName, Boolean ignoreCase, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes, Evidence securityInfo, StackCrawlMark& stackMark)
   à System.Activator.CreateInstance(String assemblyName, String typeName)
   à System.AppDomain.CreateInstance(String assemblyName, String typeName)
   à System.AppDomain.CreateInstance(String assemblyName, String typeName)
   à System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironment(String appId, IApplicationHost appHost, HostingEnvironmentParameters hostingParameters)
   à System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironmentAndReportErrors(String appId, IApplicationHost appHost, HostingEnvironmentParameters hostingParameters).

<hr />

Est ce que quelqu'un saurai comment regler le problème Merci de votre aide
Afficher la suite 

2 réponses

Répondre au sujet
jesusonline 6827 Messages postés dimanche 15 décembre 2002Date d'inscription 13 octobre 2010 Dernière intervention - 4 févr. 2008 à 20:46
+3
Utile
Bonjour,
Au niveau de l'onglet ASP.net des propriétés du site web dans IIS tu as bien .net 2.0 ?

Sinon, essaye de réinstaller .net 2.0, car le message indique qu'il n'arrive pas à trouver cette assembly ...

<hr />Cyril - MSP - MCPD ASP.net & MCTS SQL - Consultant indépendant
Cette réponse vous a-t-elle aidé ?  
Commenter la réponse de jesusonline
yanis7518 283 Messages postés mercredi 7 décembre 2005Date d'inscription 9 juillet 2010 Dernière intervention - 5 févr. 2008 à 09:11
0
Utile
bon j'ai tout desinstaller et tou reinstaller et la ca marche je comprend pas trop pourquoi

au niveau de IIS j'avais bien .net 2.0

en tout cas merci pour ton aide
Commenter la réponse de yanis7518

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.