Problème pour créer un setup

Messages postés
295
Date d'inscription
vendredi 20 décembre 2002
Statut
Membre
Dernière intervention
24 janvier 2014
- - Dernière réponse : soldier8514
Messages postés
295
Date d'inscription
vendredi 20 décembre 2002
Statut
Membre
Dernière intervention
24 janvier 2014
- 19 janv. 2008 à 21:46
une fois noël passé,
les cadeaux débalé ,

je viens d'acquérir le tout nouveau-tout beau visual studio 2008,
j'entreprends alors de créer un programme sous vb 2008 ( vb10) 

une fois celui terminé , compilé , je vérifie les dépendances du .net framework utilisé :

toutes font référence au framework 2.0  

parfait , je lance le setup wizard pour créer le fichier setup , et une fois que jai ajoutté mes fichiers compilés précédemment , le setup m'indique qu'il demandera d'installer le framework 3.5 à l'utilisateur qui installera mon programme  

cherchez l'erreur ...

Don't Hate The Hacker,  Hate The Code
Afficher la suite 

2 réponses

Messages postés
7745
Date d'inscription
mercredi 1 septembre 2004
Statut
Membre
Dernière intervention
24 septembre 2014
28
0
Merci
Pas d'erreur.

Vs2008 fonctionne sur le framework 3.5, donc quelque soit les dépendances que tu utilisera, il faudra à ton programme au minimum l'environement .Net3.5 pour fonctionner.
Il en va de même pour VS2005 et VS.Net2003

Là ou diffère VS2008, c'est qu'il introduit la possibiité de sélectionner le Framework sur lequel on souhaite développer le programme. Si 3.5 est sélectionné par défaut, tu peux choisir 2.0 ou 3.0.
Biensur dans ton programme, tu sera limité au possibilité du framework choisit, mais normalement à l'installation il ne devrait te demander que le framework choisit et non pas le 3.5.

Par contre il va te falloir fouiller, je n'ai pas VS2008 sous la main, je ne pas te dire ou se configure le framework, mais regarde déjà du coté des propriétés du projet.

Par contre je ne sais pas si on peut changer en cours de projet.

---- Sevyc64  (alias Casy) ----<hr size="2" width="100%" /># LE PARTAGE EST NOTRE FORCE #    http://aide-office-vba.monforum.com/index.php
Commenter la réponse de cs_casy
Messages postés
295
Date d'inscription
vendredi 20 décembre 2002
Statut
Membre
Dernière intervention
24 janvier 2014
1
0
Merci
tu inclues toi meme tes references dans le projet , et jai utilisé celles du 2.0 , vs 2008 ne te bloque pas à 3.5

par contre là où venait l'erreur c'est que le setup wizard te propose la version 3.5 , sans justification ,  en y regardant de plus pret , il s'agit d'une liste de framework dans laquelle on doit en sélectionner  un seul , ça parait louche car dans un programme on peut faire référence à plusieurs framework

Don't Hate The Hacker,  Hate The Code
Commenter la réponse de soldier8514