Run issue That assembly does not allow partially trusted callers [Résolu]

Messages postés
50
Date d'inscription
mardi 5 mars 2002
Statut
Membre
Dernière intervention
4 décembre 2013
- - Dernière réponse : philipina
Messages postés
50
Date d'inscription
mardi 5 mars 2002
Statut
Membre
Dernière intervention
4 décembre 2013
- 12 déc. 2007 à 15:46
Remi
Afficher la suite 

7 réponses

Meilleure réponse
Messages postés
2369
Date d'inscription
mardi 17 avril 2001
Statut
Modérateur
Dernière intervention
26 décembre 2007
13
3
Merci
Il faut que tu signes l'assembly depuis laquelle tu appelles l'assembly qui te lève cette exception.

Soit depuis Visual Studio dans les propriétés de ton projet, soit depuis le SDK avec la command sn.exe

::|The S@ib|::
MVP C#.NET

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 193 internautes nous ont dit merci ce mois-ci

Commenter la réponse de TheSaib
Messages postés
2369
Date d'inscription
mardi 17 avril 2001
Statut
Modérateur
Dernière intervention
26 décembre 2007
13
3
Merci
Il faut signer l'assembly pas le déploiement ClickOnce

::|The S@ib|::
MVP C#.NET

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 193 internautes nous ont dit merci ce mois-ci

Commenter la réponse de TheSaib
Messages postés
50
Date d'inscription
mardi 5 mars 2002
Statut
Membre
Dernière intervention
4 décembre 2013
3
Merci
Désolé, je suis newbie et donc je suis assez lent pour comprendre.
J'ai donc fait la manipulation suivante:
Dans les propriétés du projet, j'ai ouvert l'onglet "Signing", j'ai coché l'option "Sign the assembly" et j'ai choisi le fichier pfk qui avait été généré lorsque j'avais utilisé le bouton "Create Test Certificate".
Maintenant le problème est que je n'arrive plus à compiler (si je retire l'option "Sign the assembly", je peux compiler).
L'erreur de compilation est : "Assembly generation failed -- Referenced assembly 'RemotingInterfaces' does not have a strong name".


Savez-vous quelle est la prochaine étape?


Merci d'avance.


Remi.


Remi

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 193 internautes nous ont dit merci ce mois-ci

Commenter la réponse de philipina
Messages postés
2369
Date d'inscription
mardi 17 avril 2001
Statut
Modérateur
Dernière intervention
26 décembre 2007
13
3
Merci
C'est écrit il a besoin de signer l'autre assembly RemotingInterfaces.

::|The S@ib|::
MVP C#.NET

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 193 internautes nous ont dit merci ce mois-ci

Commenter la réponse de TheSaib
Messages postés
50
Date d'inscription
mardi 5 mars 2002
Statut
Membre
Dernière intervention
4 décembre 2013
3
Merci
Merci, cela fonctionne maintenant :)
J'ai également pu faire tourner mon application sans signer en allant dans l'onglet "Security" et en cochant les options "Enable ClickOnce Security settings" et "This is a full trust application".

Merci

Remi

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 193 internautes nous ont dit merci ce mois-ci

Commenter la réponse de philipina
Messages postés
50
Date d'inscription
mardi 5 mars 2002
Statut
Membre
Dernière intervention
4 décembre 2013
0
Merci
Oups, je viens de voir que le texte de ma question avait disparu.


Merci pour votre explication, je vais essayer cela.


Remi
Commenter la réponse de philipina
Messages postés
50
Date d'inscription
mardi 5 mars 2002
Statut
Membre
Dernière intervention
4 décembre 2013
0
Merci
Voilà, je viens d'aller dans les propriétés du project et dans le tab "Signing". J'ai créé un certificat de test et j'ai coché la case "Sign the ClickOnceManifest".
Le resultat est toujour le même, je continue à recevoir l'erreur "That assembly does not allow partially trusted callers."

:(

Remi
Commenter la réponse de philipina