HELP IIS 7 error Erreur HTTP 404.3

titimoun94 1 Messages postés samedi 8 décembre 2007Date d'inscription 8 décembre 2007 Dernière intervention - 8 déc. 2007 à 15:49 - Dernière réponse : kpiforever 3 Messages postés mardi 16 août 2005Date d'inscription 21 septembre 2010 Dernière intervention
- 24 août 2010 à 13:58
Bonjour ,



J'ai un probleme avec IIS 7 sous vista en ASP
Le site en ASP fonctionne tres bien sous windows XP mais lors de l'importation vers IIS 7 je n'arrive pas activer
les pages ASP.(les pages html sans asp marche tres bien)
J'ai tous tester et je n'arrive pas a trouver la solution pour que sa fonctionne

HELP HELP
Merci a vous
Voici le message d'erreur:


Erreur de serveur dans l'application "site"

<hr width= "100%" color="silver" size="1" />

Erreur HTTP 404.3 - Not Found






Description :
La page que vous avez demandée est introuvable en raison de la stratégie de mappage MIME (Multipurpose Internet Mail Extensions) configurée sur le serveur Web. La page que vous avez demandée possède une extension de nom de fichier non reconnue et non autorisée.




Code d'erreur :
0x80070032




Notification :
ExecuteRequestHandler




Module :
StaticFileModule




URL demandée :
http://127.0.0.1:80/index.asp




Chemin d'accès physique :
D:\nouve\index.asp




Session utilisateur :
Anonyme




Méthode d'ouverture de session :
Anonyme




Gestionnaire :
StaticFile




Causes les plus probables :




<li>Il se peut qu'un mappage de gestionnaire soit absent. Par défaut, le gestionnaire de fichiers statiques traite l'ensemble du contenu.
</li>
<li>La fonctionnalité que vous essayez d'utiliser n'est peut-être pas installée.
</li>
<li>Le mappage MIME approprié n'est pas activé pour le site Web ou l'application. (Avertissement : ne créez pas de mappage MIME pour un contenu que les utilisateurs ne doivent pas télécharger, comme les pages .ASPX ou les fichiers .config.) </li>



Essayez la chose suivante :




<li>Dans system.webServer/handlers :
</li>
<li>Assurez-vous que le gestionnaire attendu de la page en cours est mappé.
</li>
<li>Soyez bien attentif aux conditions préalables (par exemple, les paramètres runtimeVersion, pipelineMode, bitness) et comparez-les aux paramètres de votre pool d'applications.
</li>
<li>Soyez attentif aux erreurs typographiques dans la ligne du gestionnaire attendu.
</li>
<li>Vérifiez que la fonctionnalité que vous essayez d'utiliser est installée.
</li>
<li>Vérifiez que le mappage MIME est activé ou ajoutez-le au site Web à l'aide de l'outil de ligne de commande appcmd.exe.
<ol><li>Ouvrez une fenêtre d'invite de commandes et changez de répertoire : %windir%\system32\inetsrv.
</li><li>Pour définir un type MIME, utilisez la syntaxe suivante : appcmd set config /section:staticContent /+[fileExtension ='string',mimeType='string']
</li><li>La variable string pour fileExtension correspond à l'extension du nom de fichier et la variable string pour mimeType à la description du type de fichier.
</li><li>Par exemple, pour ajouter un mappage MIME à un fichier qui a l'extension ".xyz", tapez le texte suivant à l'invite de commandes, puis appuyez sur Entrée :
</li><li>appcmd set config /section:staticContent /+[fileExtension='.xyz',mimeType='text/plain'] </li></ol>Avertissement : Assurez-vous que ce mappage MIME est bien nécessaire avant de l'ajouter à la liste. Les fichiers de configuration tels que .CONFIG ou les pages de script dynamiques telles que .ASP ou .ASPX, ne doivent pas être téléchargées directement et doivent toujours être traitées à l'aide d'un gestionnaire. D'autres fichiers tels que les fichiers de base de données ou ceux utilisés pour stocker la configuration, tels que .XML ou .MDF, sont parfois utilisés pour stocker des informations relatives à la configuration. Indiquez si les clients peuvent télécharger ces types de fichiers avant de les activer.
</li>
<li>Créez une règle de suivi pour effectuer le suivi des demandes ayant échoué pour ce code d'état HTTP. Pour plus d'informations sur la création d'une règle de suivi pour des demandes ayant échoué, cliquez ici. </li>

Plus d'informations...Cette erreur survient lorsque l'extension de fichier de l'URL demandée est définie pour un type MIME n'étant pas configuré sur le serveur. Vous pouvez ajouter un type MIME à l'extension des fichiers ne possédant pas de pages de script dynamiques, de bases de données ou de fichiers de configuration. Utilisez un gestionnaire pour traiter ces types de fichiers. Vous ne devez pas autoriser les téléchargements directs de pages de script dynamiques, de bases de données ou de fichiers de configuration.
<hr width="100%" color="silver" size="1" />Informations de version du serveur : Services IIS 7.0.
Afficher la suite 

Votre réponse

7 réponses

quineman 72 Messages postés jeudi 30 novembre 2000Date d'inscription 10 novembre 2008 Dernière intervention - 8 avril 2008 à 23:02
0
Utile
Merci pour ton aide !
Commenter la réponse de quineman
thierry5555 19 Messages postés mardi 20 juillet 2004Date d'inscription 20 juillet 2010 Dernière intervention - 7 avril 2010 à 16:00
0
Utile
Bonjour

Et quand on à le trouble sous Windows serveur 2008 svp, je trouve pas, c'est différent (diametralement) de vista....

Merci

Thierry
Commenter la réponse de thierry5555
sarimu 13 Messages postés jeudi 28 février 2008Date d'inscription 12 mai 2010 Dernière intervention - 12 mai 2010 à 17:53
0
Utile
salut thierry5555, je sais pas si jusqu'ici t'as résolu ton pb, mais voici une solution qui devrait te satisfaire.(Descend jusqu'à la rubrique concernant Windows Server 2008)
http://learn.iis.net/page.aspx/562/classic-asp-not-installed-by-default-on-iis-70-and-iis-75/

sarimu
Commenter la réponse de sarimu
jasou62114 60 Messages postés lundi 27 février 2006Date d'inscription 20 juillet 2010 Dernière intervention - 20 juil. 2010 à 09:26
0
Utile
Merci xtof

Même 3ans après c'est toujours bon d'avoir un tel conseil. Qu'es ce qu'il est <censuré> ce serveur IIS.
Commenter la réponse de jasou62114
thierry5555 19 Messages postés mardi 20 juillet 2004Date d'inscription 20 juillet 2010 Dernière intervention - 20 juil. 2010 à 16:17
0
Utile
Bonjour

Oui c'était bien ça mais comme je le gérer sous plesk et que j'avais oublié de le coché, ça m'a mis sur le voie....

Par contre à propos de vérrouillage... Je n'arrive pas à recevoir coté cleint navigateur les erreur asp, IIS8 on bloqué l'affichage coté cleint navigateur des erreurs asp et je ne peux pas les envoyé par mail non plus la statégie de groupes ne fonctionne pas et c'est un casse tête (Pour pas dire noisettes....)

QQ à une idée pour faire apparaire les erreur asp coté client ou se les faire ,envoyer ??

Merci

Thierry
Commenter la réponse de thierry5555
kpiforever 3 Messages postés mardi 16 août 2005Date d'inscription 21 septembre 2010 Dernière intervention - 24 août 2010 à 13:58
0
Utile
La réponse de xtof est la bonne. je J'avais le même problème, et c'est comme cela que j'ai procédé
Commenter la réponse de kpiforever
cs_xtof 48 Messages postés vendredi 14 février 2003Date d'inscription 13 décembre 2007 Dernière intervention - 13 déc. 2007 à 14:37
-1
Utile
J'ai eu le même problème que toi.

Il faut que tu ailles dans le panneau de configuration, puis Programmes et Fonctionnalités Windows.

Ensuite, il faut choisir le groupe 'Services Internet (IIS)' puis 'Services World Wide Web', et enfin 'fonctionnalité de développement d'applications'.

Il suffit alors de cocher ASP.NET et de valider pour que ton site fonctionne.

++,

[ XtOf ]
Commenter la réponse de cs_xtof

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.