Petit probléme

[Résolu]
Signaler
Messages postés
58
Date d'inscription
dimanche 16 janvier 2005
Statut
Membre
Dernière intervention
26 août 2009
-
Messages postés
58
Date d'inscription
dimanche 16 janvier 2005
Statut
Membre
Dernière intervention
26 août 2009
-
bonjour , j'ai un tout petit probléme, j'arrive à afficher une page html mais quand je mets ce script en haut de page,la page html s'affiche mais le graphique est chamboulé c'est a dire qu'il ne prend pas en compte mon fichier css.KESAKO?

<?php
$langue=$_GET['langue'];
if($langue!='fr'&&$langue!='en')
 {
  $language = $_SERVER['HTTP_ACCEPT_LANGUAGE'];
  $language = $language{0}.$language{1};
   if ($language!='fr' && $language!='en')
    {
    $language='en';
    }
  
  $id=$_GET['id'];
  if ($id!='')
   {
   $id=$id.'/';
   }
  
 
 ?>


<script language="javascript" type="text/javascript">
<!--
window.location.replace("<?php echo $language; ?>/<?php echo $id; ?>" );
-->
</script>
<?php
 }
?>

3 réponses

Messages postés
13616
Date d'inscription
jeudi 13 février 2003
Statut
Membre
Dernière intervention
15 octobre 2013
36
Bonjour,
    on ne voit aucun appel à un quelconque CSS.
    on ne sait pas ce qu'il y a dans les $variables PHP.
    tout ce qu'on devine c'est : window.location.replace("en/" ); si $id est vierge... bof


       et, entre nous, pourquoi faire àà en javascript alors qu'on est en php ???



<hr />                Cordialement            Bul         [mon Site]     [M'écrire]
Messages postés
13616
Date d'inscription
jeudi 13 février 2003
Statut
Membre
Dernière intervention
15 octobre 2013
36
ne me dis pas qu'avec ma réponse ton problème est résolu ???
    parce que quand on coche "réponse acceptée", c'est ce que ça signifie.
    ou alors, au moins un message disant ce que tu as fait, par politesse...
    sinon, il nous faut plus d'infos, tout simplement.
<hr />                Cordialement            Bul         [mon Site]     [M'écrire]
Messages postés
58
Date d'inscription
dimanche 16 janvier 2005
Statut
Membre
Dernière intervention
26 août 2009

désolé de n'avoir pas repondu,c'etais du a l'url rewritting.