Pas du son dans la video!!

cs_darkos
Messages postés
15
Date d'inscription
jeudi 29 décembre 2005
Statut
Membre
Dernière intervention
21 décembre 2009
- 1 déc. 2007 à 16:03
cs_DARKSIDIOUS
Messages postés
15814
Date d'inscription
jeudi 8 août 2002
Statut
Membre
Dernière intervention
4 mars 2013
- 2 déc. 2007 à 13:26
salut !
J'utilise jmf pour la lecture video (.avi), j'ai l'image  mais pas le son.
 j'aimrais bien conaitre la cause et la solution pour régler ce probleme.
Merci a vous.

5 réponses

cs_DARKSIDIOUS
Messages postés
15814
Date d'inscription
jeudi 8 août 2002
Statut
Membre
Dernière intervention
4 mars 2013
131
1 déc. 2007 à 17:19
Salut,

Y'a-t-il une exception ? Une erreur quelconque qui s'affiche ?

Le son de la vidéo est encodé par quel codec ?
______________________________________
DarK Sidious
0
cs_darkos
Messages postés
15
Date d'inscription
jeudi 29 décembre 2005
Statut
Membre
Dernière intervention
21 décembre 2009

2 déc. 2007 à 10:26
Il m'afiche la ligne:
Unable to handle format: mpeglayer3, 48000.0 Hz, 0-bit, Stereo, Unsigned, 15999.0 frame rate, FrameSize=8 bits
que je comprend pas.
il a généré aussi un fichier log "hs_err_pid2456.log":
#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x03675065, pid=2456, tid=2616
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_11-b03 mixed mode, sharing)
# Problematic frame:
# C  [xvid.dll+0x5065]
#

avec plein d'autres  info dans le  fichier log, donc si  vous n'avez  toujours pas la réponse, je peux vous afiché tout le fichier mais je pense pas qu'il peut vous etre  utile.

sinon, comment je peut savoir quel codec il utilise?
 j'ai le codec ffdshow installé et j'ai divx aussi.
Merci encore.
0
cs_DARKSIDIOUS
Messages postés
15814
Date d'inscription
jeudi 8 août 2002
Statut
Membre
Dernière intervention
4 mars 2013
131
2 déc. 2007 à 12:19
Salut,

Les codecs installés sur ta machine ne suffise pas : Java est un langage portable, et JMF est une librairie elle aussi portable : donc peut importe les codecs installés sur ta machine, si tu n'as pas paramètré JMF pour pointer sur ces codecs, il ne les trouvera pas.

Apparement, le codec audio de ta vidéo est du mp3 (mpeglayer3), voir ici pour un plugin mp3 officiel pour le jmf : http://java.sun.com/products/java-media/jmf/mp3/download.html
______________________________________
DarK Sidious
0
cs_darkos
Messages postés
15
Date d'inscription
jeudi 29 décembre 2005
Statut
Membre
Dernière intervention
21 décembre 2009

2 déc. 2007 à 12:31
salut!
j'ais déja installé JMF MP3 Plugin, mais sa fontionne pas !!, j'ais suivie les étapes d'installation et tout devrai etre ok.
et comment je peux paramètré JMF pour pointer sur les codecs?! mais comme la video fonctionne sa ne devrai pas dire qu'il a reconnu le codec?!!
Merci encore pour ta réponse.
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
cs_DARKSIDIOUS
Messages postés
15814
Date d'inscription
jeudi 8 août 2002
Statut
Membre
Dernière intervention
4 mars 2013
131
2 déc. 2007 à 13:26
Salut,

Y'a le codec vidéo et le codec audio, qui sont 2 choses différentes.

Essaye de lancer ta vidéo avec le JMFStudio (player vidéo java qui est installé en même temps que JMF), et tu verra si ton codec audio est installé ou pas...
______________________________________
DarK Sidious
0