Roolover

Signaler
Messages postés
159
Date d'inscription
dimanche 17 juillet 2011
Statut
Membre
Dernière intervention
28 janvier 2020
-
Messages postés
3426
Date d'inscription
lundi 26 décembre 2005
Statut
Membre
Dernière intervention
14 janvier 2011
-
Bonsoir,

J'ai un soucis avec un rollover récalcitrant, je suis presque sûr que mon code est bon mais ça fait une heure que je cherche et le rollover ne veut toujours pas fonctionner ni avec IE, ni avec Firefox ni même avec Safari.
Comme vous le savez, quand on écrit quelque chose, on ne voit jamais ses fautes à sois, vaut mieux dans certains faire corriger aux autres.

Voyez-vous une erreur dans le code ci-dessous ?

<html>
<head>
<title>Véronique Cantero</title>
<meta http-equiv="imagetoolbar" content="no">
<meta name="Author" content="PetoleTeam">
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<link type="text/css" rel="STYLESHEET" href="css/style.css">
<script language="JavaScript">
bouton = new Image();
bouton.src = "boutons/archives-clic.png";
</script>
</head>

[galeries/archives/archives.htm ]

<script defer type="text/javascript" src="js/pngfix.js"></script>

</html>

Pour voir le résultat de ce que j'ai fais, c'est là : http://veronique.cantero.free.fr/archives.htm
Merci d'avance pour votre aide.

4 réponses

Messages postés
3426
Date d'inscription
lundi 26 décembre 2005
Statut
Membre
Dernière intervention
14 janvier 2011
14
Bonjour,
Essaies plutôt avec cela...
 



[la_page.html

]
 
;0)
Messages postés
159
Date d'inscription
dimanche 17 juillet 2011
Statut
Membre
Dernière intervention
28 janvier 2020

Ca marche parfaitement et ce qui est bien, c'est que du coup, il n'y a même pas besoin de mentionner les dimensions des images, impec'.

Merci.
Messages postés
159
Date d'inscription
dimanche 17 juillet 2011
Statut
Membre
Dernière intervention
28 janvier 2020

A vrai dire, ça marche au 2/3. Je me suis enflammé un peu vite. Ca marche évidemment sans problème avec Safari et Firefox mais sous IE, le rollover ne fonctionne pas mais je t'avouerai que je m'y attendais. Enfin, bon, c'est pas bien grave. Peut-être qu'il y a un conflit avec l'autre script qui permet de faire fonctionner les png 24 bits sous IE car quand ce script est désactivé, ça marche bien mais avec un abominable carré gris en guise d'arrière plan, ce qui est très disgracieux surtout pour le site d'une illustratrice.
Messages postés
3426
Date d'inscription
lundi 26 décembre 2005
Statut
Membre
Dernière intervention
14 janvier 2011
14
Bonjour,
1000 excuses je n'avais pas plus fait attention au image PNG qui bug pour l'affichage sous IE 7--
J'ai été faire un tour sur http://homepage.ntlworld.com/bobosola/png_mouseover.htm qui explique parfaitement bien le problème et le résoud aussi bien, il vaut le détour pour résoudre ton problème.
Nota : si tu passes aux images GIF le code sera dans ce cas des plus light...


;0)