Pas de debug avec VS2005/Vista Pro/IIS7

Signaler
Messages postés
3
Date d'inscription
jeudi 24 juillet 2003
Statut
Membre
Dernière intervention
26 novembre 2007
-
Messages postés
3
Date d'inscription
jeudi 24 juillet 2003
Statut
Membre
Dernière intervention
26 novembre 2007
-
Je viens de passer mon poste de développement sous Vista... et les problèmes arrivent les uns après les autres. J'ai donc bien fait passer les deux pack SP1. Puis j'ai eu un problème d'authentification ; en fouillant un peu dans le gestionnaire de service IIS, j'ai activé les authentifications (anonyme, de base et windows).
Maintenant, je n'arrive pas à faire fonctionner le debogage, pas de demande d'authentification, les points d'arrêt inopérants... Et pourtant, j'ai bien activé les débogages sur le serveur IIS7.
Est-ce que quelqu'un a rencontré le problème et quelles sont les solutions pour le résoudre ? Les recherches sur Internet n'ont rien donné de positif.
Je vous remercie d'avance pour toute piste. Sinon, il me faudrait repasser sous XP/IIS6
amezqueta

3 réponses

Messages postés
410
Date d'inscription
dimanche 1 février 2004
Statut
Membre
Dernière intervention
8 mai 2010

bonjour,
1.Pourrais-tu me dire quelle erreur est renvoyée ?
2.Qu'entends-tu par : "j'ai bien activé les débogages sur le serveur IIS7 " ?
3. es-tu allé voir les options de ton projet menu outils
@+
SuperBouly
Messages postés
3
Date d'inscription
jeudi 24 juillet 2003
Statut
Membre
Dernière intervention
26 novembre 2007

Bonjour et merci de te pencher sur mon problème,
1. Aucune erreur renvoyée et rien dans les logs de windows  (j'aurais préféré)
2. Au départ, il existe un dysfonctionnement de IIS7 lorsque l'on veut créer un site, un problème d'authentification qu'il faut régler en rajoutant un composant Window qui permet d'assurer la compatibilité de la métabase IIS6 sur IIS7. C'est ce que j'ai voulu dire par "j'ai bien activé les débogages sur le serveur IIS7 ".
3. Rien de ce côté-là. L'option "Debug=true" existe bien dans web.config.
Sur le serveur IIS, j'ai en plus activé le débogage côté client et côté serveur.
Ce qu'il se passe, c'est que lorsque je lance le site en debug pour la première fois de la session de travail, je n'ai pas de fenêtre d'autorisation d'accès sur le serveur local comme sous XP Pro/IIS6. C'est comme si je lancais le site sans debug, point d'arrêt "transparent"...
En fouinant sur Internet, j'ai vu que ce problème existe de façon récurrente (surtout sur les forum US) et qu'un moyen de le contourner est de rattacher le processus de nouveau sur le serveur web. Mais c'est un peu "rustique" comme méthode. Un truc que je viens de lire, peut-être il faut lancer VS2005 en administateur ; je testerai ce soir.
@+
amezqueta
Messages postés
3
Date d'inscription
jeudi 24 juillet 2003
Statut
Membre
Dernière intervention
26 novembre 2007

[RESOLU]



En définitive, il suffit bien tout simplement d'exécuter VS2005 en temps qu'administrateur.
amezqueta