Bien installer la fonction mail

Résolu
Billybobbonnet
Messages postés
148
Date d'inscription
lundi 12 février 2007
Statut
Membre
Dernière intervention
9 novembre 2013
- 8 nov. 2007 à 16:40
Billybobbonnet
Messages postés
148
Date d'inscription
lundi 12 février 2007
Statut
Membre
Dernière intervention
9 novembre 2013
- 1 déc. 2007 à 10:00
Bonjour à tous,

Je viens chercher conseil parce que j'essaie de mettre en place un envoi de mails via site web (en intranet) mais je sèche. Voilà donc ce que j'ai fait:

Ma fonction qui envoie les mails doit être bonne (la fonction mail toute simple) parcequ'elle a déjà marché depuis l'extérieur.

Niveau système, par contre, tout est à faire et je ne suis pas sûr de m'y être bien pris. Explication:

-J'ai un serveur apache php mysql sous windows xp, dans un intranet
-j'ai un serveur smtp unix qui fonctionne et qui sert pour envoyer des mails depuis cet intranet
- j'ai installé un MTA (comme le demande la doc de la fonction mail) dont le nom est Xmail. En guise d'installation, disons que j'ai dézippé dans un dossier.
- j'ai modifié php.ini pour les lignes suivantes:

[mail function]
; For Win32 only.
SMTP = 130.98.90.7 ; for Win32 only
sendmail_from= [mailto:monadresse@domaine.fr monadresse@domaine.fr] ; for Win32 only
sendmail_path = C:\Program Files\xmail-1.24\SendMail.exe

J'ai dû oublier un truc, mais c'est la première fois que j'essaie de faire ça. Quelqu'un aurait il un/des conseil(s), svp?

Merci!

3 réponses

Billybobbonnet
Messages postés
148
Date d'inscription
lundi 12 février 2007
Statut
Membre
Dernière intervention
9 novembre 2013

1 déc. 2007 à 10:00
Merci de tes réponses [auteur/YOMAN64/3282.aspx yoman64],

J'ai réussi à résoudre mon problème. Tout fonctionnait bien, c'était juste l'antivirus viruSscan qui bloquait le port 25 :(

Merci et bonne continuation
3
Billybobbonnet
Messages postés
148
Date d'inscription
lundi 12 février 2007
Statut
Membre
Dernière intervention
9 novembre 2013

9 nov. 2007 à 09:17
Personne? Je prends tous les conseils qu'on peut me donner, si tant est qu'on veuille bien m'en donner!
0
yoman64
Messages postés
962
Date d'inscription
samedi 19 janvier 2002
Statut
Membre
Dernière intervention
2 août 2010
1
27 nov. 2007 à 05:56
Salut

senmail_path est pour unix, sur windows tu dois utilisé l'adresse du smtp.

Premièrement ton serveur smtp fonctionne t-il ?
est-ce que ton serveur web est capable d'y acceder autrement ?
Essait par exemple dans une fenetre de cmmande: ping le-ip-de-ton-serveur-smtp , est-ce que ça répond?
Si oui, tu peux tenté un telnet voir si tu peux t'y connecté

Et aussi tu devrais véifié si ta fonction mail ne renvois pas d'erreur!

-------------------
Vous cherchez un hebergement Php/MySQL Gratuit et sans publicités ??
Et bien c'est la : www.e3b.org 
0