.net framework [Résolu]

Signaler
Messages postés
5
Date d'inscription
samedi 17 février 2007
Statut
Membre
Dernière intervention
23 juillet 2008
-
Messages postés
5
Date d'inscription
samedi 17 février 2007
Statut
Membre
Dernière intervention
23 juillet 2008
-
Salut à Tous,
Je débute dans le prog sous VB 2005, et dès mon premier programme, je suis calé. En effet après compilation, en installant le programme sur d'autres machines, le truc me demande, soit d'installer le Framework 2, soit il dit que le framework 2 est absent. Alors je demande quand est ce que j'ai du manquer quelque chose, ou est ce qu'on est vraiement obligé de passer par cette installation du framework.
Merci aussi de m'indiquer le lien, si le sujet est déjà traité quelque part.
Merci à tous.



Regarde au déla de tout ce que tu vois

10 réponses

Messages postés
918
Date d'inscription
vendredi 3 août 2007
Statut
Membre
Dernière intervention
27 octobre 2008
10
Salut !
En effet, pour une appli en VB2005, il te faut absolument le framework .NET version 2.0 isntallé sur les machines cible.
Tous les objets, toutes les classes que tu utilises en programmant en VB2005 sont situées dans le framework. Il te faut donc celui-ci sur une machine pour que ton exe fonctionne.
Normalement, une machine XP en SP2 qui se met à jour via le service Windows Update est OK de ce coté.
Sinon, tu peux télécharger celui-ci depuis le site de Microsoft et l'installer directement.
Messages postés
918
Date d'inscription
vendredi 3 août 2007
Statut
Membre
Dernière intervention
27 octobre 2008
10
Messages postés
5
Date d'inscription
samedi 17 février 2007
Statut
Membre
Dernière intervention
23 juillet 2008

Kristof_Koder > Merci beaucoup pour la reponse si vite.
Juste une autre question? Y-a-til d'autre facon (ou logiciel) de programmer qui ne demande pas cela. Je veux dire, je telecharge certains programmes sur ce site où j'essai de les installer sur ces machines (qui n'ont pas le framework.net) et cela marche sans problème.
Salutations.

Regarde au déla de tout ce que tu vois
Messages postés
918
Date d'inscription
vendredi 3 août 2007
Statut
Membre
Dernière intervention
27 octobre 2008
10
ooui ... tu peux coder en C/C++ natif ou bien même en ASM
Messages postés
5
Date d'inscription
samedi 17 février 2007
Statut
Membre
Dernière intervention
23 juillet 2008

Merci bcp Kristof_Koder,



En C/C++, je suis formaté, je dois partir de zéro, mais ASM c'est quoi exactement?



Merci



Regarde au déla de tout ce que tu vois
Messages postés
5487
Date d'inscription
dimanche 4 août 2002
Statut
Modérateur
Dernière intervention
20 juin 2013
56
l'asm? va voire par ici: http://www.asmfr.com/
Sinon dans vista et certainement tous les prochains windows, le framework est inclus 'nativement'

<hr />
-My Blog-
Messages postés
206
Date d'inscription
lundi 22 novembre 1999
Statut
Membre
Dernière intervention
3 juillet 2008

Wai,

Ce qui laisse peu d'espoir de voir son appli tourner sur toutes les plateformes win32, c'est bien dommage quand meme :/
Je me souviens d'une version de VB DOS 1.0 qui compilée ne necessitait aucune DLL ou runtime supplémentaire, ce qui a changé à partir de VB 2.0 :)
L'évolution c'est bien, mais restreindre à 1 ou 2 version d'un 'meme' OS c'est quand meme dommage... c'est aussi pour cela que j'ai développé mon propre langage 'compilable' en EXE 32 bits autonaume et qui tourne sous Win985, 98, ME, NT, 2k, XP, 2003 et Vista sans soucis et sans runtime supplémentaire, et... cerise sur le gateau : ça ressemble à du VB dans la syntaxe, et pour les amateurs il est aussi OOP

Gérôme GUILLEMIN
Auteur du langage FBSL
Messages postés
918
Date d'inscription
vendredi 3 août 2007
Statut
Membre
Dernière intervention
27 octobre 2008
10
"Ce qui laisse peu d'espoir de voir son appli tourner sur toutes les plateformes win32" < Je ne comprend ta remarque !?
Messages postés
206
Date d'inscription
lundi 22 novembre 1999
Statut
Membre
Dernière intervention
3 juillet 2008

Bé oui, le framework net ne tourne pas correctement sur toutes les plateformes, celui qui supporte encore 98 est le 1.0, le 1.1 ne tourne deja plus sous NT4, alors que le 2.0 ne tourne sue sous 2000 et >.

Oui .NET est tres bien mais pas pour faire des application WinForm, mais tes bien pour des applis Web ( Webservices, ASPX etc... )

Gérôme GUILLEMIN
Auteur du langage FBSL
Messages postés
5
Date d'inscription
samedi 17 février 2007
Statut
Membre
Dernière intervention
23 juillet 2008

Merci à tous.



Regarde au déla de tout ce que tu vois