Problme caracteres spéciaux - recherche

[Résolu]
Signaler
Messages postés
503
Date d'inscription
mercredi 29 décembre 2004
Statut
Membre
Dernière intervention
20 mars 2012
-
Messages postés
503
Date d'inscription
mercredi 29 décembre 2004
Statut
Membre
Dernière intervention
20 mars 2012
-
Bonjour,
Je viens vers vous car je galère depuis 2 jours et je n'ai pas trouvé de solution.
je suis entrain de developper une application web sous windows et easy php 1.7,
dans mon application il y a une grande partie de recherche, y a des liste que je remplie à partir de la base de données mysql.
Sous easy php, tous ça marche très bien.
mais lorsque j'ai exporté cette application vers linux (ubuntu), lorsque je fais la recherche sur des mot sans caractères spéciaux ça marche imprec, mais si je fais des recherches sur des mots qui contiennent par exemple 'é' ça ne marche pas !

Voilà comment je remplie la liste :
while($array = mysql_fetch_array($req_))
            {
$famille .= '<option value="'.$array1['famille'].'">'.$array1['famille']).'</option>';
            }
et voilà comment je fais la recherche :

$res_req=mysql_query('SELECT famille FROM tablee
WHERE famille like "%'.$famille.'%" ');//$famille est recupée à partir de $_POST
merci pour vos aide.

N'importe où. 
mais là où il le faut.

1 réponse

Messages postés
503
Date d'inscription
mercredi 29 décembre 2004
Statut
Membre
Dernière intervention
20 mars 2012

voici l'astuce pour y rémédier...

Definir le charset par defaut de vos sites dans Apache2

Ouvrez le fichier dans /etc/apache2/ portant le nom 'apache2.conf'
machine:~# nano /etc/apache2/apache2.conf

En gros en bas du fichier 'apache2.conf' décommentez cette ligne:
DefaultLanguage fr

avec aussi
AddDefaultCharset ISO-8859-1

Ouvrez un nouveau fichier dans /etc/apache2/conf.d portant le nom 'charset'
Si ce fichier ne s'y trouve pas bien sur....
machine:~# touch /etc/apache2/conf.d/charset
machine:~# nano /etc/apache2/conf.d/charset

Inserez ceci dedans ou modifiez la ligne de utf-8 à ISO-8859-1 ou ISO-8859-15 (Pour afficher le symbole ? aussi )

Comme ceci:
AddDefaultCharset ISO-8859-1

Rechargez la configuration Apache2
machine:~# /etc/init.d/apache2 reload &amp;&amp; /etc/init.d/apache2 restart


Bon courage, Younes BOUAMOUT - Maroc

N'importe où. 
mais là où il le faut.