Problème de repositionnement de page lorsque je selectionne une valeur dans une [Résolu]

Signaler
Messages postés
4
Date d'inscription
lundi 9 août 2004
Statut
Membre
Dernière intervention
22 octobre 2007
-
Messages postés
4
Date d'inscription
lundi 9 août 2004
Statut
Membre
Dernière intervention
22 octobre 2007
-
Bonjour,

j'ai une page web dans lequel j'ai plusieurs users controls. (lables, dropdownlists, richtext, etc...)

J'ai un problème assez génant c'est que lorsque je sélectionne un valeur dans une drop down list, mon ascenceur remonte un peu.

Je pense donc que ce problème apparaît lors du postback.

Quelqu'un pourrait-il m'aider ?

Merci d'avance

4 réponses

Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
28
Bonjour,

rajoute la propriété maintainScrollPositionOnPostBack="true" dans la directive de page.

<hr />Cyril - MSP - MCPD ASP.net & MCTS SQL - Consultant indépendant
Messages postés
4
Date d'inscription
lundi 9 août 2004
Statut
Membre
Dernière intervention
22 octobre 2007

Hello,

alors c'était effectivement le focus qui gachait tout !

J'ai réussi à l'enlever.

J'ai ajouter à la directive de ma page smartNavigation="true" pour blocker l'ascenceur.

Maintenant ça fonctionne à merveille !

Merci pour ton aide jesusonline !
Messages postés
4
Date d'inscription
lundi 9 août 2004
Statut
Membre
Dernière intervention
22 octobre 2007

Salut,

j'ai oublié de préciser que le site est du .Net 1.1.

Quand j'ajoute la propriété maintainScrollPositionOnPostBack="true" à ma page, cela me donne l'erreure suivante :

Parser Error
Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: The 'maintainScrollPositionOnPostBack' attribute is not supported by the 'page' directive.
Messages postés
4
Date d'inscription
lundi 9 août 2004
Statut
Membre
Dernière intervention
22 octobre 2007

Hello,

j'ai cherché un peu ce matin et apparement l'équivalent en .NET 1.1 c'est smartNavigation="true".

Par contre cela ne fonctionne pas.

Par contre je pense avoir trouvé la cause de mon problème. Il y a un focus qui se fait automatiquement sur un composant Infragistics (webHtmlEditor).

Quelqu'un sait comment suffrimer le focus sur cet élément ?