Petit problème avec My.Computer.Network.ping

Signaler
Messages postés
11
Date d'inscription
vendredi 5 octobre 2007
Statut
Membre
Dernière intervention
5 décembre 2007
-
Messages postés
11
Date d'inscription
vendredi 5 octobre 2007
Statut
Membre
Dernière intervention
5 décembre 2007
-
Bonjour à tous,

Voilà j'ai un petit souci avec un de mes programmes.

Au chargement de mon formulaire j'ai inséré ce code :

Try

My.Computer.Network.Ping(
"Mon_serveur")Shell(

"net use r: [file://\\mon_serveur\mon-repertoire \\mon_serveur\mon-repertoire] /user:mon_utilisateur")

Catch ex
As ExceptionMessageBox.Show(

"Pas de réseau ou réseau injoignable" & vbCrLf & ex.Message)

End
Try

Le problème c'est que il me dit que je n'ai pas de réseau alors que je suis connecté et il me plante avec une erreur que je ne comprends pas du tout.

"Echec de la demande d'authoriqation de type 'system.Net.NetworkInformation.NetworkInformationPermission, System, Version=2.0.0.0, Culture=neutral, publicKeyToken=b77a5c561934e089'

Lorsque je lance un debuggage il me met que "Une exception de première chance de type 'System.Security.SecurityException' s'est produite dans mscorlib.dll"

Ce qui m'étonne le plus c'est que j'ai développé mon prog sous VIsta et Visual basic express edition 2005 (tout marchait bien). J'ai réinstallé mon PC avec un XP pour gagné un peu en puissance et me voilà avec cette erreur !!!

Vista aurait-il fait des siennes ou c'est moi ???

Merci en tout cas pour vos suggestions.

The Matrix has You

4 réponses

Messages postés
918
Date d'inscription
vendredi 3 août 2007
Statut
Membre
Dernière intervention
27 octobre 2008
10
Regarde du coté des propriété de sécurité de ton projet. J'ai eu le même genre de message concernant une connexion coté SQLClient et j'ai résolu le pb comme ca
Messages postés
11
Date d'inscription
vendredi 5 octobre 2007
Statut
Membre
Dernière intervention
5 décembre 2007

Salut,

J'ai fait un clic droit sur le nom de mon projet et suis allé sur propriété. Je suis allé ensuite sur l'onglet sécurité j'ai activé l'option "Activer les paramètres de sécurité ClickOnce" (qui était décoché) et j'ai mis "il s'agit d'une application de confiance totale", mais j'ai le même problème !!!

Merci pour ton aide

The Matrix has You
Messages postés
918
Date d'inscription
vendredi 3 août 2007
Statut
Membre
Dernière intervention
27 octobre 2008
10
en tout cas, chez moi (XP SP2 + VB Express 2005) ton p'tit bout de code fonctionne nickel.
Messages postés
11
Date d'inscription
vendredi 5 octobre 2007
Statut
Membre
Dernière intervention
5 décembre 2007

Salut à tous,

Bon c'est vrai que c'est un peu tard mais j'ai trouvé le truc. En faite, je démarrer mon code depuis un amplacement réseau et ca apparement il aime pas du tout.

Maintenant que je le lance en local sur mon poste tout marche nickel.

The Matrix has You