Super débutant MSQLi [Résolu]

ydu 61 Messages postés mercredi 1 mars 2006Date d'inscription 6 août 2009 Dernière intervention - 13 oct. 2007 à 09:27 - Dernière réponse : Teclis01 1423 Messages postés mardi 14 décembre 2004Date d'inscription 29 décembre 2012 Dernière intervention
- 14 oct. 2007 à 01:50
Bonjour tout le monde,

Avant tout je tiens a vous préciser, je suis un SD "Super Débutant". En effet, je me suis fourni PHP & Mysql pour les nuls.

Me voila planter en page 30 mdr ca commence bien et j'ai donc besoin de votre aide.

j'ai installé easyPhp2 tournant avec PHP5.

Le test PHP tourne nickel.
Par contre le test Mysql c'est pas la cas. Dans le livre il parle de Mysqli qui semble comporter plus de fonction que Mysql et vu qu'il semble l'utiliser tout au long du livre je suis obligé de m'y mettre si je veux espérer suivre.

voici le code qui plante:
'***********************************************************
<?php
/* Programme: mysqli_up.php
 * Desc: Se connecte au Serveur mysqli et affiche les parametres
*/

echo "<html>
    <head><tittle> Test de mysqli5 avec php5 </tittle></head>
    ";

    $host= "localhost";
    $user="";
    $password="";

$cxn=mysqli_connect($host,$user,$password);
$sql="SHOW STATUS";
$result=mysqli_query($cxn,$sql);

if ($result==false)
    {
    echo "Erreur: ".mysqli_error($cxn)."
";
    }
    else
    {
    /*tableau affichant les resultats*/
    echo "    ----
Nom_variable |
        Valeur |\";

for ($i =0;$i<mysqli_num_rows($result);$i++)
    {
    echo\"\";
    $rows_array= mysqli_fetch_row($result);
        for ($j=0;$j<mysqli_num_fields($result);$j++)
        {
        echo\"".$rows_array[$j].", \n\";
        }   
    }
echo"
";
}
?>

</html>

'******************************************************'
voici l'erreur à la compilation via FireFox.

Test de mysqli5 avec php5
Warning : mysqli_connect() [function.mysqli-connect]: (28000/1045): Accès refusé pour l'utilisateur: 'ODBC'@'@localhost' (mot de passe: NON) in C:\Program Files\EasyPHP 2.0b1\www\test-mysql.php on line 14

Warning: mysqli_query() expects parameter 1 to be mysqli, boolean given in C:\Program Files\EasyPHP 2.0b1\www\test-mysql.php on line 16

Warning: mysqli_error() expects parameter 1 to be mysqli, boolean given in C:\Program Files\EasyPHP 2.0b1\www\test-mysql.php on line 20
Erreur:
  ===> de ma propre initiative, je me suis rendu dans al config de easyphp2 et j'ai coché les extansions suivantes.

php_msql
php_mssql
php_mysql
php_mysqli

Merci d'avance pour votre patience ainsi que pour vos explications  pour un SD que je suis ! lol

@+
ydu
Afficher la suite 

Votre réponse

3 réponses

Meilleure réponse
Teclis01 1423 Messages postés mardi 14 décembre 2004Date d'inscription 29 décembre 2012 Dernière intervention - 13 oct. 2007 à 10:50
3
Merci
1/ 
Warning: mysqli_connect() [function.mysqli-connect]: (28000/1045): Accès refusé pour l'utilisateur: 'ODBC'@'@localhost' (mot de passe: NON) in C:\Program Files\EasyPHP 2.0b1\www\test-mysql.php on line 14
2/
Warning: mysqli_query() expects parameter 1 to be mysqli, boolean given in C:\Program Files\EasyPHP 2.0b1\www\test-mysql.php on line 16
3/
Warning: mysqli_error() expects parameter 1 to be mysqli, boolean given in C:\Program Files\EasyPHP 2.0b1\www\test-mysql.php on line 20

1/
ça vient de ceci (mais aussi du fait que la ressource retourné n'est pas testée) :
    $host="localhost";
    $user="";
    $password="";
essaye cela
    $host="localhost";
    $user="root";
    $password="";

2 et 3/
ceci vient du probleme traité en 1/

Good Luck and May the force be with You
--------------------------------------------------------------------------------------------------
         Il vaut mieux poser une question et passer pour bête que le rester toute sa vie

Merci Teclis01 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 70 internautes ce mois-ci

Commenter la réponse de Teclis01
ydu 61 Messages postés mercredi 1 mars 2006Date d'inscription 6 août 2009 Dernière intervention - 13 oct. 2007 à 14:49
0
Merci
Teclis Merci beaucoup et très certainement ......... à tres bientot malheureusement :-) lol

Ps: il fallait juste mettre user="root"

@+
ydu
Commenter la réponse de ydu
Teclis01 1423 Messages postés mardi 14 décembre 2004Date d'inscription 29 décembre 2012 Dernière intervention - 14 oct. 2007 à 01:50
0
Merci
Pour la petite histoire, easyphp et/ou wamp sont configuré ainsi de base
A bientot ;)

--------------------------------------------------------------------------------------------------
         Il vaut mieux poser une question et passer pour bête que le rester toute sa vie
Commenter la réponse de Teclis01

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.