Web-Site et Publication

Signaler
Messages postés
18
Date d'inscription
mercredi 26 novembre 2003
Statut
Membre
Dernière intervention
21 mars 2008
-
Messages postés
18
Date d'inscription
mercredi 26 novembre 2003
Statut
Membre
Dernière intervention
21 mars 2008
-
Bonjour,

je vous présente le topo:

Outil: Visual Studio 2005 SP1 Version US - WindowsXP SP2

J'ai créé une solution comprenant 4 projets créé par différents développeurs, la compilation se fait dans cet ordre:
- Un projet <ClasseCS> Class Library en C# : Des classes en C#
- Un projet <ClasseVB> Class Lobrary en VB.Net : Des classes en VB.Net, utilisant certaines classes en C#
- Un projet <Forum> Class Library en C# : la classe du forum utilisant certaines classes en C# et VB.Net
- Un Web-Site en .aspx et .vb : Comprenant des pages, dossier, sous dossier et un forum Utilisant toutes les classes

Le site se compile très bien en mode debug, on peut le tester, tout marche nickel.

Le problème se pose lorsque je veux publier le site dans un dossier. Il indique que la publication est reussit mais aucun fichier n'est présent dans le dossier de destination.
Voici ce qui me met à la fin :
======== Build: 4 succeeded or up-to-date, 0 failed, 0 skipped ==========

======== Publish: 1 succeeded, 0 failed, 0 skipped ==========

Voila, si vous avez besoin d'autres infos, n'hésitez pas à me le demander.

Merci d'avance !

3 réponses

Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
28
Bonjour,

comment fais tu le publish ? regarde avec Filemon (utilitaire sysinternals qui liste tous les accès fichiers) pour voir si Visual Studio écrit et où.

<hr />Cyril - MSP - MCPD ASP.net & MCTS SQL - Consultant indépendant
Messages postés
18
Date d'inscription
mercredi 26 novembre 2003
Statut
Membre
Dernière intervention
21 mars 2008

Salut,

Pour la publication, j'ai essayé avec <Clic droit sur le projet web site, Publish Web Site>.
J'ai aussi essayé avec le fichier dans le dossier <C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>

Alors, j'ai regarder avec le logiciel que tu m'as recommandé. Il commence à créer les fichiers pour le projet ClasseCS, puis ceux de ClasseVB. Il commence ensuite à générer les fichiers pour le projet Forum, puis tout d'un coup il s'arrete sans dire pourquoi, sans message d'erreur et indique que la publication est terminé avec succes.

Voila, merci.
Messages postés
18
Date d'inscription
mercredi 26 novembre 2003
Statut
Membre
Dernière intervention
21 mars 2008

Salut,

J'ai enfin reussit a précompiler le site !

je vous explique ce qui a empêchait le bon fonctionnement:

Dans le site dont je m'occupais, les anciens développeurs avaient fait des copier-coller de page sans changer le nom de la classe du fichier aspx.vb. De ce fait des donblons de classe étaient présents.

De plus, il y avait un projet, un forum AspNetForums, qui était en framework 1.1, alors que le site utilise le framework 2.0.
Ce qui perturbait la précompilation sans pour autant bloquer la compilation en mode debug.

Après avoir retiré le forum, et renommé correctement les classes, la précompile à refonctionné.

Voila.