MODBUS TCP

Signaler
Messages postés
7
Date d'inscription
lundi 13 février 2006
Statut
Membre
Dernière intervention
5 décembre 2007
-
Messages postés
1172
Date d'inscription
jeudi 24 mai 2007
Statut
Membre
Dernière intervention
28 septembre 2013
-
Bonjour à tous,

je voulais savoir si quelqu'un peut m'aider pour établir une communication entre un programme vb.net et un automate type TSX Premium. Il faut utiliser le protocole ModBus TCP avec la carte Ethernet donc. Mais je n'ai pas trouvé de librairie ou de code source pour développer cette communication.

Je veux lire et écrire des mots de l'automate soit un par un soit par lot.

N.B. : si vous n'avez pas la solution complète, je veux bien toute documentation à ce sujet ou ebauche de code.

Merci

9 réponses

Messages postés
1172
Date d'inscription
jeudi 24 mai 2007
Statut
Membre
Dernière intervention
28 septembre 2013
1
salut, demande à chorus direct, ils ont des serveurs OPC pour faire cela.
j'ai déja vu des soluces la dessus sur ce site (je crois) mais pas le temps de chercher :p

pense à poster ta réponse si tu en a une car cela interssera d'autre membre ;)
(dont moi, si cela se trouve ^^)
++

Tiens les balises ne sont pas reconnues ^_____^, zut alors.....
Messages postés
7
Date d'inscription
lundi 13 février 2006
Statut
Membre
Dernière intervention
5 décembre 2007

Merci de ta réponse très rapide,mais en fait, je recherche de la doc ou des sources pour développer la com en interne et ne pas avoir à payer une licence supplémentaire.

Je voudrais développer un driver de communication pour lire ou écrire des mots dans l'automate.
Messages postés
1172
Date d'inscription
jeudi 24 mai 2007
Statut
Membre
Dernière intervention
28 septembre 2013
1
intéréssant comme sujet, j'aimerai bien aussi ^^
je te propose d'autres forum plus dédié API vas voir :
http://www.aei-formation.com/FORUM/index.php4 (je post un topic la dessus=> admin powaaa ^^)
http://automa.free.fr/
http://automatica.xooit.com/index.php
http://www.telemecanique.com/85256E54006445AD/all/ACE59BD6E20C731485256DE500655DEF/$  (exemple de com modbus avec un altivar)

Un des soucis que l'on va rencontrer et la couche matérielle ! il s'agit d'un RS485 alors que les pc sont en RS232, un convertisseur est donc necessaire (le protocole lui n'a rien à voir avec la couche materielle)

courage et tiens moi au jus cela m'interesse aussi (dés que minute je m'y lance aussi)

Tiens les balises ne sont pas reconnues ^_____^, zut alors.....
Messages postés
7
Date d'inscription
lundi 13 février 2006
Statut
Membre
Dernière intervention
5 décembre 2007

Juste pour recadrer ma demande, je recherche une communication sur Ethernet avec la carte réseau du PC connecté sur la carte ETY PORT de l'automate donc. (pas de RS232)
Merci encore pour les infos
Messages postés
1172
Date d'inscription
jeudi 24 mai 2007
Statut
Membre
Dernière intervention
28 septembre 2013
1
oups boulet que je suis tu es en TCP

tiens surveille aussi les réponses ici => http://www.aei-formation.com/FORUM/viewtopic.php4?p=1060#1060

++

Tiens les balises ne sont pas reconnues ^_____^, zut alors.....
Messages postés
7
Date d'inscription
lundi 13 février 2006
Statut
Membre
Dernière intervention
5 décembre 2007

Bon et bien après tout ce temps, je pense m'approcher d'une solution temporaire à tester qui permet de lire et écrire des WORD dans un automate TSX en communication avec ETY PROT (Ethernet Modbus).

Je continue mes recherches et mon développement avant de poster des résultats qui ne sont pas encore concluant.

Merci à tous
Messages postés
1172
Date d'inscription
jeudi 24 mai 2007
Statut
Membre
Dernière intervention
28 septembre 2013
1
Cool ! tiens j'ai trouvé cela (c'est du VB6) il y a les codes sources pour du tcp et/ou rs232 (j'ai un peu de mal à piger comment il gére son truc mais bon) en espérant que cela puisse t'aider
http://www.modbus.pl/vb.htm
Tiens les balises ne sont pas reconnues ^_____^, zut alors.....
Messages postés
2
Date d'inscription
lundi 14 avril 2003
Statut
Membre
Dernière intervention
23 avril 2008

merci pour votre aide
Messages postés
1172
Date d'inscription
jeudi 24 mai 2007
Statut
Membre
Dernière intervention
28 septembre 2013
1
Je veux bien lire ta salution si tu en as trouvé une ! J'ai trouvé de mon coté une class de com TCP/Modbus mais je n'ai aucune réponse dans l'evenement de reception sur une requéte -_-, pourtant l'API (un Wago) est bien en ligne... @ te lire
Tiens les balises ne sont pas reconnues ^_____^, zut alors.....