Service qui refuse de démarrer (1053) [Résolu]

Messages postés
814
Date d'inscription
vendredi 3 novembre 2000
Statut
Membre
Dernière intervention
30 juillet 2009
- - Dernière réponse : cs_Loda
Messages postés
814
Date d'inscription
vendredi 3 novembre 2000
Statut
Membre
Dernière intervention
30 juillet 2009
- 25 sept. 2007 à 10:24
Salut tout le monde!

en ce moment, j'ai un problème avec mon service windows que je commence a croire insoluble....

le service refuse de démarrer (dans services.msc). Il indique un code d'erreur 1053 (ERROR_SERVICE_REQUEST_TIMEOUT). Je pense que ce code d'erreur est "faux" vu qu'il apparaît quasi instantanément.

Des tests par élimination m'ont permit de trouver la ligne qui pose problème:

var
monInstanceDInterface: IMonInterface;
begin
exit; //ajouter pour tester
monInstanceDInterface := MaFunctionDansMaDLL;// function 'external' retournant une nouvelle instance d'interface depuis une DLL.

si cette ligne est présente (même si non appelé), mon service ne démarre pas.

moi, j'ai essayé tout les trucs que je connais et je suis à court d'idées...

je suis ouvert à toute proposition., si vous avez eut un problème similaire ou si vous pouvez m'aider, cela serra très apprécié.

merci d'avance!

Loda

précision:
j'ai bien mis sharemem.

le %path% est correct.

cette dll est utilisé dans d'autre projet et fonctionne bien.
la version 'form' de mon service functionne sans problème.
je suis loin ce week-end.
je suis vraiement ouvert à toute propositions.
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
814
Date d'inscription
vendredi 3 novembre 2000
Statut
Membre
Dernière intervention
30 juillet 2009
3
3
Merci
bon bon,

j'ai toujours pas trouvé pourquoi cela ne marche pas.

MAIS, cela ne marche pas que sur ma machine. Alors, je laisse béton.

merci quand même,

Loda
<hr size="2" width="100%" />Se poser les bonnes questions est le premier pas pour trouver les bonnes réponses.

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 219 internautes nous ont dit merci ce mois-ci

Commenter la réponse de cs_Loda
Messages postés
93
Date d'inscription
mardi 11 avril 2006
Statut
Membre
Dernière intervention
4 mars 2009
0
Merci
Salut loda

Si tu es vraiment ouvert à toute proposition alors passe sous Linux !

Je plaiantais !

Je regarderai Lundi au boulot ce que j'ai là-dessus.

sylvunix
Commenter la réponse de sylvunix
Messages postés
814
Date d'inscription
vendredi 3 novembre 2000
Statut
Membre
Dernière intervention
30 juillet 2009
3
0
Merci
hehe,

ici (barcelone),  on a congé lundi....

merci d'avance,

Loda
<hr size="2" width="100%" />Se poser les bonnes questions est le premier pas pour trouver les bonnes réponses.
Commenter la réponse de cs_Loda