Problème d'execution

Signaler
Messages postés
2
Date d'inscription
samedi 28 novembre 2020
Statut
Membre
Dernière intervention
28 novembre 2020
-
Messages postés
4718
Date d'inscription
dimanche 26 février 2006
Statut
Modérateur
Dernière intervention
14 janvier 2021
-
Bonjour,
j'ai crée une application avec delphi 10.3 rio de embarcadero je les terminé quand je l'exécute elle marche très bien sont problème , j'ai fais mes bases de donner avec Access 2007 .
quand je crée un exécutable avec inosetup il marche tres bien sur mon pc.
mes quand je le copie et j'essaye de le faire marcher sur un autre micro ça marche pas.
j'ai essayer de copie les tables + Install Access 2007 rien a faire il marche pas.
il me dit pilote ISAM Introuvable . en suite il me demande les chemin des tables qui existe dans mon programme .puis quand je vais au tables Access que j'ai copie je les trouve avec un cadenas.
merci pour votre patiente besoin d'aide.

2 réponses

Messages postés
375
Date d'inscription
vendredi 20 octobre 2000
Statut
Modérateur
Dernière intervention
15 janvier 2021

Bonjour cholite

Ça doit être un problème de droits soit sur la base de données soit droits système.
Messages postés
4718
Date d'inscription
dimanche 26 février 2006
Statut
Modérateur
Dernière intervention
14 janvier 2021
14
Bonjour,

Dans une installation, il faut TOUT prévoir :
- les droits d'accès à la base de données
- la copie de la base de données pour une installation en monoposte
et les chemin d'accès qui bien entendu ne sont pas codés en dur et éventuellement
les bibliothèques aussi.
donc, il faut refaire ton installation sous InnoSetup.

nb : access en local ça marche plutôt bien

cantador