Envoi de mails via CDO ne fonctionne plus

Signaler
Messages postés
794
Date d'inscription
mercredi 4 août 2010
Statut
Membre
Dernière intervention
9 août 2020
-
Bonjour,
Un de mes programmes VB6 envoie des mails via CDO depuis longtemps sans problème.
Subitement je ne reçois plus les mails alors que je n'ai rien changé au code, je n'ai pas d'erreur.
Voici le code; j'ai remplacé "http://schemas.microsoft.com/cdo/configuration" par "..." pour vous faciliter la lecture, évidement j'ai la référence à cdosys.dll
6900  Set ObjSendMail = CreateObject("CDO.Message")
ObjSendMail.Configuration.Fields.Item(".../sendusing") = 2  'Send the message using the network (SMTP over the network).
ObjSendMail.Configuration.Fields.Item(".../smtpserver") = "send.one.com"
ObjSendMail.Configuration.Fields.Item(".../smtpserverport") = 465
ObjSendMail.Configuration.Fields.Item(".../smtpusessl") = True  'Use SSL for the connection (True or False)
ObjSendMail.Configuration.Fields.Item(".../smtpconnectiontimeout") = 60
ObjSendMail.Configuration.Fields.Item(".../smtpauthenticate") = 1  'basic (clear-text) authentication
ObjSendMail.Configuration.Fields.Item(".../sendusername") = "my user name"
ObjSendMail.Configuration.Fields.Item(".../sendpassword") = "my password"
ObjSendMail.Configuration.Fields.Update
ObjSendMail.From = "from mail address"
ObjSendMail.To = "adresse mail du destinataire"
ObjSendMail.Subject = "le sujet"
ObjSendMail.TextBody = "Bonjour, ..."
ObjSendMail.Send
Set ObjSendMail = Nothing
Pourriez-vous m'aider à débusquer le problème ?
Merci