La méthode ~ de l'objet ~ a échoué

Messages postés
551
Date d'inscription
mercredi 4 août 2010
Statut
Membre
Dernière intervention
3 octobre 2019
- - Dernière réponse : JeuDuTaquin
Messages postés
124
Date d'inscription
mardi 4 juillet 2017
Statut
Membre
Dernière intervention
17 octobre 2019
- 17 oct. 2019 à 04:05
Bonjour,
De temps en temps en démarrant l'IDE de VB6 j'obtiens ce message

Je ferme puis ouvre à nouveau, parfois j'ai à nouveau le même message, puis il disparaît.
A quoi est-il du ?
Quand ce message apparaît vaut-il mieux quitter et recommencer ou puis-je continuer sans problème ?
Merci d'avance pour votre avis.
Afficher la suite 

3 réponses

Messages postés
14565
Date d'inscription
vendredi 14 mars 2003
Statut
Modérateur
Dernière intervention
13 octobre 2019
136
0
Merci
Pendant son démarrage, l'IDE de VB6 utilise le presse papier, si tu fais des opérations dedans, tu peux avoir ce message.
Il peut aussi apparaître si tu lance plusieurs instance de l'IDE en simultané.
Commenter la réponse de NHenry
Messages postés
124
Date d'inscription
mardi 4 juillet 2017
Statut
Membre
Dernière intervention
17 octobre 2019
1
0
Merci
Salut,
Même chose sur VB5, après l'activation d' "add-ins" (visual component manager).
On peut tous les désactiver, modifier ou effacer le fichier "ini".
Mais, l'IDE devient de plus en plus instable au fil des mises à jours Windows… (path; erreurs aléatoires et latences antivirus)
Vérifier les paths des dépendances dans le fichier "VBP", "C:\WINDOWS\SYSTEM" devient "C:\Windows\SysWOW64\" sur W10... en cas de plantages à la compilation ou au démarrage ("memory full"/log au démarrage -clé de registre non valide).
Commenter la réponse de JeuDuTaquin
Messages postés
124
Date d'inscription
mardi 4 juillet 2017
Statut
Membre
Dernière intervention
17 octobre 2019
1
0
Merci
Salut Hervé,

J'ai résolu le problème en forçant l'executable du compilateur en mode "administrateur" sous W10.

Il te suffit de chercher le fichier "VB6.exe" dans ton répertoire "C:\Program Files (x86)\", puis de cliquer l'executable sur le bouton droit.



Tu cliques [Propiétés], puis l'option d'indexe [Compatibilité].
En bas tu as une case à cocher "[-] Exécuter en tant qu'administrateur." dans la sections "paramètres".
Tu la valides et tu fermes.

Ton IDE va maintenant s'ouvrir correctement, mais il te faudra valider l'execution du programme avec l'écran gris foncé de sécurité… à chaque fois.

(ça marche pour le VB5, aussi)

Amuse-toi bien.
Commenter la réponse de JeuDuTaquin