Suppression dans fichier XML

Signaler
Messages postés
29
Date d'inscription
lundi 25 février 2019
Statut
Membre
Dernière intervention
24 novembre 2019
-
Messages postés
29
Date d'inscription
lundi 25 février 2019
Statut
Membre
Dernière intervention
24 novembre 2019
-
Bonjour,
J'essaye de supprimer une balise dans un fichier xml, mais rien à faire, j'ai testé removechild, marche pas.
Voici ce que je voudrais faire :

<?xml version="1.0" encoding="utf-8"?>
<lstSite>
  <Zone>
    <Page_Zone>xxxxxxxxxxxxxx</Page_Zone>
    <Nombre_de_pages>37</Nombre_de_pages>
  </Zone>
  <Perso>    
   <Page_Perso>xxxxxxxxxxxxxxxxxxx</Page_Perso>
</Perso>
</lstSite>


Supprimer par exemple la ligne <Nombre_de_pages> (pas modif, mais delete).
J'ai cherché sur le net, mais rien ne fonctionne , j'ai très mal compris j'en suis sur.
Jean

1 réponse

Messages postés
14582
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
7 août 2020
426
Bonjour
Dans ma boule de cristal, il me semble coir qu’il manque un ; à la ligne 32.

Bon sérieusement, tu as essayé removechild ok mais dans quel contexte?
Si tu veux qu’on ait une possibilité de te répondre correctement, il faut poster le code que tu as essayé.
Et si tu veux qu’on ait envie de lire ton, il est fortement conseillé d’utiliser correctement la coloration syntaxique, voir ici https://codes-sources.commentcamarche.net/faq/11288-les-balises-de-code
Messages postés
29
Date d'inscription
lundi 25 février 2019
Statut
Membre
Dernière intervention
24 novembre 2019

Ok, suis désolé, je refais
Messages postés
29
Date d'inscription
lundi 25 février 2019
Statut
Membre
Dernière intervention
24 novembre 2019

bon ben je crois que en envoyant, j'ai perdu ma demande, pas de confirme bien envoyé. j'ai fait prévu, puis valider et plus rien
Messages postés
29
Date d'inscription
lundi 25 février 2019
Statut
Membre
Dernière intervention
24 novembre 2019

je ne retrouve plus mes messages