Installation du logiciel Eclipse

- - Dernière réponse : KX
Messages postés
16093
Date d'inscription
samedi 31 mai 2008
Statut
Modérateur
Dernière intervention
11 décembre 2019
- 22 oct. 2017 à 12:39
Salut à tous !
je veux débuter avec la programmation en java avec le logiciel "Eclipse" mais j'ai un petit souci. j'ai son .exe, lorsque j'essaie de l'installer ça me renvoie des Erreurs du genre :
"Version 1.2.3 of the JVM is not suitable for this product. Version 1.7 or greater is required. "
Je ne comprend pas tout ça !
Pourriez-vous m'aider pour installer ce logiciel ?
Merci d'avance!
Afficher la suite 

1 réponse

Messages postés
14042
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
13 décembre 2019
324
0
Merci
Bonjour,

si tu veux apprendre à programmer, c'est un gros plus de comprendre l'anglais.
Quasiment tous les langages sont basés sur l'anglais, les mots, clés, les messages d'erreur, la doc...
Et une grande part de ce que l'on trouve sur le net est en anglais.

Ce message veut dire que sur ton ordinateur, la machine virtuelle java (indispensable pour le fonctionnement de tout programme java) n'est pas de la bonne version, il faut la version 1.7 au minimum.

https://www.java.com/fr/download/
KX
Messages postés
16093
Date d'inscription
samedi 31 mai 2008
Statut
Modérateur
Dernière intervention
11 décembre 2019
88 -
Bonjour,

Pour exécuter Eclipse, la JRE de java.com est suffisante, mais pour développer des programmes Java il faudra en plus le kit de développement (JDK)

http://www.oracle.com/technetwork/java/javase/downloads/jdk9-downloads-3848520.html

Remarque : je serais curieux de savoir comment tu as pu installer un Java 1.2.3 alors que Java 2 (sorti en 1998 !!) s'arrête à la 1.2.2_017
Commenter la réponse de Whismeril