Bug Avec Webclient.uploadFile

Signaler
Messages postés
30
Date d'inscription
dimanche 10 décembre 2006
Statut
Membre
Dernière intervention
15 avril 2008
-
Messages postés
30
Date d'inscription
dimanche 10 décembre 2006
Statut
Membre
Dernière intervention
15 avril 2008
-
J'ai un probleme l'orsque j'essai d'uploader des gros fichiers (videos) sur un serveur

J'essai d'uploader des videos sur un site de partage de video genre YouTube.
Le site utilise un bete formulaire input file enctype= multipart/form-data
le fichier est envoyé par methode POST

J'ai deux problemes lorsque j'utilise la methode Webclient.UploadFile

*Parfois j'obtient l'exeption suivante apres quelque minutes d'upload ou carement au démarrage :
La connexion sous-jacente a été fermée : Une erreur inattendue s'est produite lors de la réception
*le téléchargement se termine brusquement  (passe de 60% a 100% par exemple) et j'obtient quand meme une réponse du serveur (Upload Completed, Video Id 01234, video title ....)

Le probleme est que dans le deuxieme cas je n'ai pas la possibilité de savoir si le fichier a été correctement télécharger ou non, car j'effectue ces Upload sur un serveur tiers.

Quelqu'un sais comment résoudre un des deux problemes. ou au moin m'expliquer son origine?

Merci bcp, ce probleme me gene vraiment

1 réponse

Messages postés
30
Date d'inscription
dimanche 10 décembre 2006
Statut
Membre
Dernière intervention
15 avril 2008

Bon apperement pour le deuxieme cas il y a un décalage entre la property progresspercentage et le rapport entre données envoyés et données totales a envoyer
(le transfert est completed vers les 50%)
Donc mes fichiers sont reelement reçu par le serveur (et puis je recevai une réponse du serveur)

Mais jai toujours

"La connexion sous-jacente a été fermée : Une erreur inattendue s'est produite lors de la réception"

Qui est lancé de temps à autre