[XSL] XPath grammar problem to test '

Messages postés
3
Date d'inscription
mardi 11 juillet 2017
Dernière intervention
11 juillet 2017
- - Dernière réponse : dodododododod
Messages postés
3
Date d'inscription
mardi 11 juillet 2017
Dernière intervention
11 juillet 2017
- 11 juil. 2017 à 10:48
J'essayer de tester (<xsl:if test=''>) le symbole &coma; mais il est interprété directement donc ''' n'est plus valide..
J'obtiens l'erreur : The expression around 'translate(substring($str, $i, 1),translate(., ''', ''), '')' is not a valid instance of the XPath grammar.
Est-ce que quelqu'un sait comment faire pour faire un test sur une apostrophe ?

Merci d'avance
Afficher la suite 

Votre réponse

3 réponses

Messages postés
12388
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
14 décembre 2018
0
Merci
Bonjour

C'est quoi ton langage?
Commenter la réponse de Whismeril
Messages postés
3
Date d'inscription
mardi 11 juillet 2017
Dernière intervention
11 juillet 2017
0
Merci
Erratum : c'est le symble ' dont je parle.
Commenter la réponse de dodododododod
Messages postés
3
Date d'inscription
mardi 11 juillet 2017
Dernière intervention
11 juillet 2017
0
Merci
C'est une transformation XSL (XSLT).
Et si je mets "& apos;", ça ne fonctionne pas puisque ça correspond à '''.. :/
Commenter la réponse de dodododododod

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.