Code pour automatiser un calcul de tri (Do Until?)

Signaler
Messages postés
9
Date d'inscription
dimanche 7 août 2016
Statut
Membre
Dernière intervention
24 mai 2017
-
Bonjour,
Je cherche un code (ou une formule) qui me permette de trouver un nombre X, de telle sorte que, la formule contenant X soit égale à un nombre le plus proche possible de Y%. Soit quelque chose comme sa:

- La valeur de X est affichée dans la cellule A1
- La formule ci dessous est affichée dans la cellule B1:

B1=ARRONDI( TRI((A1,D2,D3,D4,...)), sachant que
B1< Y%.

- La valeur de Y% est affichée dans la cellule C1: l'objectif est d'obtenir en B1 une valeur le plus proche possible de C1, mais sans être = à C1


Par exemple:
Soit Y%= 10%, je cherche X, afin qu'en appliquant la formule, je trouve un nombre en B1 le plus proche possible de 10%. B1 = 9,8% ou B1= 9,9%. Mais B1 doit être différent de 10%. B1 doit approcher C1 sans être égal.

Pour celà je fait varier X de 0,01. J'ai utilisé un énorme tableau contenant en colonne les valeurs de X (X=1; 1,01; 1,02;...200). Et dans une 2ème colonne le calcul ARRONDI(TRI(...))J'aimerai ne plus avoir à tirer un tableau sur 1000 lignes pour trouver la solution.

Je vous serai très reconnaissante si vous pouviez encore faire un miracle ;)