Base de données

Signaler
Messages postés
6
Date d'inscription
jeudi 27 septembre 2012
Statut
Membre
Dernière intervention
4 mars 2017
-
Messages postés
211
Date d'inscription
samedi 15 novembre 2003
Statut
Membre
Dernière intervention
10 juin 2021
-
Salut tout le monde,
je suis en train de développé une application sous DELPHI 7 entreprise avec une base de données Paradox .
Le problème est :
- Au lancement de l’application elle prend beaucoup de temps, ce temps augmente jour après jour (aujourd’hui=12 minutes)
- le système insère dans mon projet des fichiers bizarre de type (_QSQ1.db,…) , et ces fichiers reste mêmes quand je ferme l’application.

- Comment résoudre le problème de la lenteur de démarrage de l'application ?

- Comment empêcher l’apparaisse ce genre des fichiers ?

- Est-ce qu’il y a une relation entre la lenteur de démarrage de l’application et ces fichiers ?

Merci d'avance



--

2 réponses

Messages postés
211
Date d'inscription
samedi 15 novembre 2003
Statut
Membre
Dernière intervention
10 juin 2021
10
salut
je crois que la réponse t'as été donnée
ici https://www.developpez.net/forums/d1644102/environnements-developpement/delphi/base-donnees/

ce sont des fichiers crées par le BDE qui s'effacent à la fermeture du programme.
Si ils persistent c'est qu'il y a une ou plusieurs erreurs dans ton prog.
Messages postés
6
Date d'inscription
jeudi 27 septembre 2012
Statut
Membre
Dernière intervention
4 mars 2017

Merci papyvore
Peut-être mon programme contient des erreurs, mais de quels genres ?
Je crois que l'application marche.
Messages postés
211
Date d'inscription
samedi 15 novembre 2003
Statut
Membre
Dernière intervention
10 juin 2021
10
ton application marche ???
a t elle marché correctement a un moment,et tu aurais fait une modif ???
quel genre d'erreur ? il faudrait voir ton code.
Essais un pas a pas peut être tu verras quelque chose .
perso je n'utilise plus paradox , tu devrais changer de base.