Résistance des matériaux avec Excel (sans macros)

Signaler
Messages postés
261
Date d'inscription
mardi 12 décembre 2006
Statut
Membre
Dernière intervention
10 juin 2019
-
William VOIROL
Messages postés
261
Date d'inscription
mardi 12 décembre 2006
Statut
Membre
Dernière intervention
10 juin 2019
-
Cette discussion concerne un article du site. Pour la consulter dans son contexte d'origine, cliquez sur le lien ci-dessous.

https://codes-sources.commentcamarche.net/source/101558-resistance-des-materiaux-avec-excel-sans-macros

vb95
Messages postés
2099
Date d'inscription
samedi 11 janvier 2014
Statut
Contributeur
Dernière intervention
2 avril 2020
89
bonsoir
Vu que c'est réalisé avec Excel pourquoi avoir mis ce code dans Visual Basic / VB Net ?
Il aurait été plus logique dans Visual Basic / VBA
Par contre je ne jugerai point le code : je ne suis pas du tout un spécialiste Excel j
William VOIROL
Messages postés
261
Date d'inscription
mardi 12 décembre 2006
Statut
Membre
Dernière intervention
10 juin 2019
> vb95
Messages postés
2099
Date d'inscription
samedi 11 janvier 2014
Statut
Contributeur
Dernière intervention
2 avril 2020

Bonjour,

A mon avis, il n'est pas possible de placer un code dans
Visual Basic / VB Net ni dans
Visual Basic / VBA.

Peut-être voulez-vous parler des emplacements
Visual Basic / VB.NET - VB.NET et
Visual Basic / VB.NET - VBA ?

Actuellement, le code est déposé dans
Visual Basic / VB.NET - Divers, car il m'a paru peu clair de le ranger dans
Visual Basic / VB.NET - VBA alors que justement, il ne contient pas de code VGA!

Si vous pensez qu'il est plus habituel (logique ?) de le placer dans
Visual Basic / VB.NET - VBA, alors je l'y déplacerais volontiers.
vb95
Messages postés
2099
Date d'inscription
samedi 11 janvier 2014
Statut
Contributeur
Dernière intervention
2 avril 2020
89 > William VOIROL
Messages postés
261
Date d'inscription
mardi 12 décembre 2006
Statut
Membre
Dernière intervention
10 juin 2019

Bonjour
ton application est une application purement "Excel" d'accord
Bien qu'il n'y a aucun code VBA d'après toi ( donc aucune macros ni fonctions ou Sub VBA) il ne semble plus logique de le mettre dans Visual Basic / VB.NET - VBA,
On pourrait même dire que ce code n'a rien à faire sur ce forum vu qu'il n'y a aucun code VBA mais ce serait pas cool de notre part !
Et rien n’empêche une personne qui le téléchargerait d'y adjoindre des options supplémentaires avec du code VBA ou sans code VBA
> vb95
Messages postés
2099
Date d'inscription
samedi 11 janvier 2014
Statut
Contributeur
Dernière intervention
2 avril 2020

Bonjour,
Merci pour ce fichier très pratique.Par contre il y a une erreur sur le calcul de la flèche en flexion cellule I23:
la formule doit être : =SI(D23=0;0;F23*(H11^3)/D5/D23/J23) et non pas =SI(D23=0;0;G23*H11^2/D5/D23/J23).
William VOIROL
Messages postés
261
Date d'inscription
mardi 12 décembre 2006
Statut
Membre
Dernière intervention
10 juin 2019
> laurent
Bonjour laurent,

Analysons la formule que vous proposez:
|i23| =SI(D23=0;0;F23*(H11^3)/D5/D23/J23):

I32 = f (flèche)
F23 = F (ou G, force ponctuelle ou répartie)
H11 = l (longueur)
D5 = E (module d'élasticité)
D23 = I (moment d'inertie)
J23 = k (diviseur pour la flèche: voir zone Fix)

Donc: f = F•l³/(E•I•k). ce qui est tout-à-fait correct.


En ce qui concerne la formule actuelle:
|i23| =SI(D23=0;0;G23*H11^2/D5/D23/J23):

avec G23 = M (moment) = F•l/K: |G23| =F23*H11/C23
et C23 = K (diviseur pour la contrainte: voir zone Fix).

Donc f = F•l³/(E•I•k•K). ce qui est faux, car le bon résultat est encore divisé par K.

Manifestement, vous avez découvert une erreur que s'est introduite dans mon programme, et je vous remercie vivement de me l'avoir signalée.

Je vais rapidement corriger les 3 versions (fr, de, en) contenus dans le zip.