Débutante: faire afficher une forme à partir d'un choix de list

- - Dernière réponse : ucfoutu
Messages postés
18039
Date d'inscription
lundi 7 décembre 2009
Statut
Modérateur
Dernière intervention
11 avril 2018
- 5 juin 2016 à 08:23
Bonjour,

Cela fait 4 jours que j'essais d'enregistrer une macro, je cherche plein d'information sur le net à ce sujet.

J'ai un fichier Excel avec 2 listes déroulantes:
- la 1ère : choix -> super, bien, nul (A1)
- la 2ème : choix -> excellent, super, bien, nul (B1)
Lors des 2 choix faits, j'aimerai faire apparaître un rond de couleur verte sur une cellule.
Si le 1er choix est super et le 2eme est excellent, il faut faire afficher le rond dans une certaine cellule choisie (D1), si d'autres choix sont faits, mettre la position du rond en conséquence aux endroits définis (D2 ou D3 ou D4 ... -> 12 cellules différentes -> choix différents max).
Quelqu'un aurait une idée, svp?

Mon code de départ:
Private Sub Worksheet_Change(ByVal Target As Range)
If [E] = "test 1" Then MacroA
If [E] = "test 2" Then MacroB
If [E] = "test 3" Then MacroC
If [E] = "" Then MacroD
End Sub
Sub MacroA()
'
' MacroA Macro

ActiveSheet.Paste

Range("F2").Select
End Sub

Je sais qu'il manque pleins d'informations mais je m'arrache les cheveux, je suis débutante.

Merci par avance.
Afficher la suite 

Votre réponse

1 réponse

Meilleure réponse
Messages postés
18039
Date d'inscription
lundi 7 décembre 2009
Statut
Modérateur
Dernière intervention
11 avril 2018
1
Merci
Bon ...
Nous sommes dimanche et :
- tu ne connais très manifestement (à divers titres) rien de VBA
- tu as également de grandes difficultés à exposer clairement les choses
Je vais tenter de te tendre une perche simple, adaptée à ton niveau et sans le moindre code VBA.
1) Liminaire : qu'est un "rond" ? La lettre O en est un, entre autres
2) fais donc ce petit test sur un classeur tout neuf
- sélectionne la colonne C ==>> Format ==>> Police (mets la en gras, taille 20 et couleur verte) ===>> Alignement (choisis "horizontal" puis "centré)
- va maintenant en cellule C1 et mets-y cette formule toute bête (les formules Excel ne sont pas du VBA)
=SI(ET(A1 = "xxx";B1= "yyy");"O";"")

- sors des formules, sélectionne C1 ===>> copie ===>> sélectionne maintenant de C2 à C20 et colle
Regarde maintenant ce qui se passe en colonne C si tu écris xxx en colonne A et yyy en colonne B d'une ligne
Voilà. A toi de savoir au moins te servir ce ces bases qui (je le répète) ne nécessitent que la connaissance de Excel et rien de VBA.

________________________
Nul ne saurait valablement coder ce qu'il ne saurait exposer clairement.

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources a aidé 106 internautes ce mois-ci

Commenter la réponse de ucfoutu

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.