RechercheV Python ? [Résolu]

Aminos17 22 Messages postés vendredi 6 juin 2014Date d'inscription 18 juillet 2015 Dernière intervention - 13 juil. 2015 à 05:33 - Dernière réponse : Aminos17 22 Messages postés vendredi 6 juin 2014Date d'inscription 18 juillet 2015 Dernière intervention
- 16 juil. 2015 à 14:40
Bonjours tout le monde !
y'a pas longtemps j'ai commençais a apprendre Python et j'ai un petit programme que je voudrais réaliser je vous explique :
dans un fichier Excel j'ai 3 colonnes :

-Hauteur
-A301
-A302

(ça représente un Bac de remplissage Chaque Hauteur renvois a une valeur sur la même linge pour A301 et A302 qui représente leur volume et qui bien sur une valeur que j'ai !)

j'aimerais pouvoir taper la Hauteur et recevoir comme résultat le volume de A301 et le volume de A302 pour mieux comprendre je vous est mis un échantillon de ce fichier Excel avec 40 linge vu que le fichier o complet vas a plus de 16000 linge d'ou l'utilité de la recherche :p
( car je suis amené a recevoir la Hauteur puis chercher le volume qui lui correspond dans les deux bacs pour les envoyer )
je crois que le module Xlrd peut satisfaire mes besoin mais j'ai pas réussis a l'utiliser comme il faut :/

Voila le fichier : http://www.mediafire.com/download/1orh5dsczkk8ezj/Baremage.xlsx

Ps : j'ai la version 3.4 de Python et aussi la 2.7.10 mais je préfère la 3.X vu que j'ai appris les base avec :)

Merci de m'accorder votre temps et votre patience !
Afficher la suite 

Votre réponse

5 réponses

Mints 70 Messages postés mercredi 1 novembre 2000Date d'inscription 1 juin 2018 Dernière intervention - 13 juil. 2015 à 10:31
0
Merci
Salut, pour résoudre ton problème je pense que la meilleure solution serait d'utiliser un dictionnaire qui aurait pour clés les hauteurs et pour chacune d'elles les 2 valeurs de A301 et A302 correspondantes.
Tu peux regarder par ici dans un premier temps : http://apprendre-python.com/page-apprendre-dictionnaire-python

J'espère que cela t'aidera, cordialement.

Mints

--
Aminos17 22 Messages postés vendredi 6 juin 2014Date d'inscription 18 juillet 2015 Dernière intervention - 13 juil. 2015 à 14:44
Merci Mints pour ta réactivité :)
je sais faire un dictionnaire mais j'ai plus de 16000 linge d'Hauteur et (dans la même linge 2 valeur une pour A301 et l'autre A302) donc je peut pas les taper un a un en les séparent avec les ':' c'est pour ça que je veux relier mon python avec le fichier Excel qui contient le tout :p
Commenter la réponse de Mints
Mints 70 Messages postés mercredi 1 novembre 2000Date d'inscription 1 juin 2018 Dernière intervention - 13 juil. 2015 à 16:24
0
Merci
Re, j'aimerai savoir si tu veux faire un petit programme pour t'exercer en python dans ce but ou si tu n'as pas réussi à mettre en place une recherche dans excel.En attendant ta réponse pour la recherche via excel j'ai peut être une solution dont voici un screen :


Avec en J2 : =RECHERCHEV(G2;A2:C16000;2) pour obtenir A301
et en L2 : =RECHERCHEV(G2;A2:C16000;3) pour obtenir A302
en G2 la valeur de la hauteur recherchée

Maintenant tu as peut-être déjà fait tout ça et tu veux peut-être coder un programme python pour x raisons, auquel cas il existe effectivement des modules de lecture de feuille excel dont j'ai juste survolé les possibilités pour le moment en attendant ta réponse.

Cordialement.Mints
--
Aminos17 22 Messages postés vendredi 6 juin 2014Date d'inscription 18 juillet 2015 Dernière intervention - 13 juil. 2015 à 21:55
Bon je t'explique :
- j'ai déjà réussis a faire la RechercheV sur Excel :)
- je ne fais pas ça dans le but de m'exercer mon but finale est de crée un programme avec une interface graphique avec une Case pour entrer la Hauteur et deux case en bas(ou on peut pas entrer du texte :p ça vas de soit) une qui renvois A301 et l'autre A302
>>> Mais pour le moment je me concentrer d'avoir un code solide fonctionnelle puis je me débrouillais pour une interface graphique (Sauf si tu peut m'aider dans ce cote aussi :p je t'en remercie
>>Mon travaille fonctionne ainsi : on me dit une valeur de Hauteur je vais chercher Le Volume dans les deux bacs J'AI déjà a réussis a faire cette recherche sur Excel avec succès mais je voudrait crée une app que pourras par exemple utiliser mes collèges simple et efficace :)
Commenter la réponse de Mints
Aminos17 22 Messages postés vendredi 6 juin 2014Date d'inscription 18 juillet 2015 Dernière intervention - 16 juil. 2015 à 14:40
0
Merci
Merci pour vos réponse ! j'ai trouver la soluc dans un autre forum :
#Importation des tableau :
from xlrd import open_workbook
xl_workbook = open_workbook('C:\\Users\\ammar\\Desktop\\PythonAMS\\N.xlsx')
xl_sheet = xl_workbook.sheet_by_index(0) # you only have one sheet in your file
data = {}
for row_index in range(1, xl_sheet.nrows) : # 0 = header
row = xl_sheet.row(row_index)
data[int(row[0].value)] = [int(value.value) for value in row[1:]]

#Demande de tirage :
Hauteur = int(input("Entrer la hauteur : "))
print (data[Hauteur])
Commenter la réponse de Aminos17

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.