Mail(): SMTP server response: 503 RCPT first [Résolu]

cs_Ma2004 150 Messages postés mardi 20 juillet 2004Date d'inscription 22 octobre 2008 Dernière intervention - 31 août 2007 à 14:17 - Dernière réponse : trifplusnomore1241 2 Messages postés dimanche 28 décembre 2008Date d'inscription 1 avril 2010 Dernière intervention
- 6 mai 2009 à 17:57
Bonjour,

J'ai programmé une page qui va chercher des adresses dans une base de données et envoie un mail à chacune d'entre elles via la fonction mail.
La première adresse trouvée fonctionne bien. Par contre, dès la seconde adresse, j'ai le message suivant: "mail(): SMTP server response: 503 RCPT first" et évidemment le mail correspondant et les suivants ne s'envoient pas.
Quelqu'un a une idée de la signification et de l'origine de ce message ?

D'avance merci.

==============================================================
Si cette réponse convient à ton problème, n'oublies pas de l'accepter 
Afficher la suite 

3 réponses

Répondre au sujet
cs_Ma2004 150 Messages postés mardi 20 juillet 2004Date d'inscription 22 octobre 2008 Dernière intervention - 31 août 2007 à 15:53
+3
Utile
Merci pour ta réponse mais elle ne solutionne pas mon problème. Le serveur SMTP est correctement paramétré dans mon php.ini. Par ailleurs, j'avais déjà cherché sur Google, Yahoo et Exalead sans trouver la solution !
 
En fait, j'ai continué à chercher et je viens de comprendre ce que celà signifiait exactement: "RCTP" fait référence au(x) destinataire du mail envoyé. "First" c'est "d'abord", donc, simplement, (et écrit comme ça, ça va être tout bête) avant d'envoyer un mail, il faut stipuler un destinataire. Comme lors d'un envoi postal, c'est plus pratique de mettre l'adresse sur l'enveloppe avant de la poster !!
J'ai donc vérifié mes destinataires et écarté toutes les lignes où l'adresse email n'apparaissait pas. Le tour est joué, ça fonctionne parfaitement bien.

Merci encore en tout cas d'avoir pris le temps de m'envoyer une réponse.

==============================================================
 
Cette réponse vous a-t-elle aidé ?  
Commenter la réponse de cs_Ma2004
kishkaya 366 Messages postés samedi 26 juin 2004Date d'inscription 17 avril 2008 Dernière intervention - 31 août 2007 à 15:37
0
Utile
Mets l'adresse du smtp dans php.ini.

PS: GOOGLE EST TON AMI : Ya plus qu'a cliquer

_Marikou
Commenter la réponse de kishkaya
trifplusnomore1241 2 Messages postés dimanche 28 décembre 2008Date d'inscription 1 avril 2010 Dernière intervention - 6 mai 2009 à 17:57
0
Utile
bonjour,

je suis actuellement sur un projet E-commerce en stage de fin d'études et là j'y suis arrivé à l'étape e-mailing. et j'ai fais un petit programme en php exactement comme toi, il récupère les adresses de la base appartenant à une catégorie spécifique et envoi par la suite à chacune.
et je n'arrête pas d'avoir l'erreur suivante:    Warning: mail(): SMTP server response: 530 5.7.0 Must issue a STARTTLS command first. 5sm1878737eyh.10.             
et pour le php.ini  j'ai pris le soin de le configurer.

j'ai compris ce que tu voulais dire mais en essayant j'ai eu le même msg d'erreur. donc si tu as d'autres eclaircissements à rajouter n'hésites pas ca pourrai toujours servir.
 
Cordialement.
Commenter la réponse de trifplusnomore1241

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.