Voici mon problème.

Signaler
Messages postés
2
Date d'inscription
dimanche 12 octobre 2014
Statut
Membre
Dernière intervention
12 octobre 2014
-
Messages postés
2
Date d'inscription
dimanche 12 octobre 2014
Statut
Membre
Dernière intervention
12 octobre 2014
-
Salut à tous et à toute

je suis entrain de développer un programme en utilisant Ado connexion rad STUDIO XE3 (Delphi XE3) . le programme se compile et s'exécute bien. Même en exécutant l'.exe le programme s'exécute correctement. j'ai créé le setup.exe, après installation, en cliquant sur le raccourcir du bureau, le programme ne s'exécute pas, il déclenche une erreur en cherchant la base de données sur le bureau, en laçant l'exécution depuis menu démarrer, il cherche la base de données dans le system32 MAIS en renvoyant un autre raccourcis vers le bureau depuis le dossier d'installation crée sur le c:\ contenant la base de données, le problème ne se pose plus. Aidez-moi !!!

2 réponses

Messages postés
33731
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
22 octobre 2021
353
Bonjour,
Vu les symptômes que tu nous décris... il semble que tu es utilisé un chemin relatif pour ta base de données...
Le chemin correspondant à la directory d'exécution du programme....;

Il te faut donc regarder dans ton code à quel endroit tu déclares l'emplacement de ta BDD ... et modifier la façon dont tu l'as fait.

Messages postés
2
Date d'inscription
dimanche 12 octobre 2014
Statut
Membre
Dernière intervention
12 octobre 2014

Salut Jordane,

Merci bien pour vos remarques.

Pour le problème, je tiens à vous dire que j'ai défini un chemin d'accès libre à ma base de données. Toute fois je vais revoir mon code. Je tien à vous remercier pour votre soutien.


Cordialement, CHRIS.