Projet d'installation

Signaler
Messages postés
91
Date d'inscription
dimanche 12 août 2007
Statut
Membre
Dernière intervention
21 septembre 2014
-
cs_rinuom99
Messages postés
91
Date d'inscription
dimanche 12 août 2007
Statut
Membre
Dernière intervention
21 septembre 2014
-
Bonjour,

je viens de terminer ma petite application qui fonctionne avec Express sql server. après la génération du programme d'installation, j'ai installer l'application sur autres pc mais elle ne fonctionne pas et elle m'affiche un message d'erreur : l'application a cessé de fonctionner, fichiers aident a décrire le problème:
voici les fichiers
1- WER4904.tmp.appcompat :
<?xml version="1.0" encoding="UTF-16"?>
<DATABASE>
<EXE NAME="SuiviRegime.exe" FILTER="CMI_FILTER_PRIVACY">
    <MATCHING_FILE NAME="SuiviRegime.exe" SIZE="93184" CHECKSUM="0x6CA43C07" BIN_FILE_VERSION="1.0.0.0" BIN_PRODUCT_VERSION="1.0.0.0" PRODUCT_VERSION="1.0.0.0" FILE_DESCRIPTION="SuiviRegime" PRODUCT_NAME="SuiviRegime" FILE_VERSION="1.0.0.0" ORIGINAL_FILENAME="SuiviRegime.exe" INTERNAL_NAME="SuiviRegime.exe" LEGAL_COPYRIGHT="Copyright ©  2014" VERDATEHI="0x0" VERDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x1" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="1.0.0.0" UPTO_BIN_PRODUCT_VERSION="1.0.0.0" LINK_DATE="09/21/2014 09:27:09" UPTO_LINK_DATE="09/21/2014 09:27:09" VER_LANGUAGE="Langue neutre [0x0]" EXE_WRAPPER="0x0" />
</EXE>
<EXE NAME="KERNELBASE.dll" FILTER="CMI_FILTER_THISFILEONLY">
    <MATCHING_FILE NAME="KernelBase.dll" SIZE="274944" CHECKSUM="0x81EAFB25" BIN_FILE_VERSION="6.1.7601.18409" BIN_PRODUCT_VERSION="6.1.7601.18409" PRODUCT_VERSION="6.1.7601.18015" FILE_DESCRIPTION="DLL du client API BASE Windows NT" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Système d'exploitation Microsoft® Windows®" FILE_VERSION="6.1.7601.18015 (win7sp1_gdr.121129-1432)" ORIGINAL_FILENAME="Kernelbase" INTERNAL_NAME="Kernelbase" LEGAL_COPYRIGHT="© Microsoft Corporation. Tous droits réservés." VERDATEHI="0x0" VERDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x49E52" LINKER_VERSION="0x60001" UPTO_BIN_FILE_VERSION="6.1.7601.18409" UPTO_BIN_PRODUCT_VERSION="6.1.7601.18409" LINK_DATE="03/04/2014 09:19:02" UPTO_LINK_DATE="03/04/2014 09:19:02" EXPORT_NAME="KERNELBASE.dll" VER_LANGUAGE="Français (France) [0x40c]" EXE_WRAPPER="0x0" />
</EXE>
<EXE NAME="kernel32.dll" FILTER="CMI_FILTER_THISFILEONLY">
    <MATCHING_FILE NAME="kernel32.dll" SIZE="1114112" CHECKSUM="0x5B25986C" BIN_FILE_VERSION="6.1.7601.18409" BIN_PRODUCT_VERSION="6.1.7601.18409" PRODUCT_VERSION="6.1.7601.18015" FILE_DESCRIPTION="DLL du client API BASE Windows NT" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Système d'exploitation Microsoft® Windows®" FILE_VERSION="6.1.7601.18015 (win7sp1_gdr.121129-1432)" ORIGINAL_FILENAME="kernel32" INTERNAL_NAME="kernel32" LEGAL_COPYRIGHT="© Microsoft Corporation. Tous droits réservés." VERDATEHI="0x0" VERDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x1105AE" LINKER_VERSION="0x60001" UPTO_BIN_FILE_VERSION="6.1.7601.18409" UPTO_BIN_PRODUCT_VERSION="6.1.7601.18409" LINK_DATE="03/04/2014 09:19:01" UPTO_LINK_DATE="03/04/2014 09:19:01" EXPORT_NAME="KERNEL32.dll" VER_LANGUAGE="Français (France) [0x40c]" EXE_WRAPPER="0x0" />
</EXE>
</DATABASE>


2- WER2AAB.tmp.WERInternalMetadata :
<?xml version="1.0" encoding="UTF-16"?>
<WERReportMetadata>
 <OSVersionInformation>
  <WindowsNTVersion>6.1</WindowsNTVersion>
  <Build>7601 Service Pack 1</Build>
  <Product>(0x30): Windows 7 Professional</Product>
  <Edition>Professional</Edition>
  <BuildString>7601.18409.amd64fre.win7sp1_gdr.140303-2144</BuildString>
  <Revision>1130</Revision>
  <Flavor>Multiprocessor Free</Flavor>
  <Architecture>X64</Architecture>
  <LCID>1036</LCID>
 </OSVersionInformation>
 <ProblemSignatures>
  <EventType>CLR20r3</EventType>
  <Parameter0>suiviregime.exe</Parameter0>
  <Parameter1>1.0.0.0</Parameter1>
  <Parameter2>541e99ed</Parameter2>
  <Parameter3>System.Data</Parameter3>
  <Parameter4>4.0.30319.18408</Parameter4>
  <Parameter5>52311175</Parameter5>
  <Parameter6>25c0</Parameter6>
  <Parameter7>27</Parameter7>
  <Parameter8>System.Data.SqlClient.Sql</Parameter8>
 </ProblemSignatures>
 <DynamicSignatures>
  <Parameter1>6.1.7601.2.1.0.256.48</Parameter1>
  <Parameter2>1036</Parameter2>
  <Parameter22>0a9e</Parameter22>
  <Parameter23>0a9e372d3b4ad19135b953a78882e789</Parameter23>
  <Parameter24>0a9e</Parameter24>
  <Parameter25>0a9e372d3b4ad19135b953a78882e789</Parameter25>
 </DynamicSignatures>
 <SystemInformation>
  <MID>655A41E9-A160-4813-878A-906FF5D9E43B</MID>
  <MarkerFile>103C_HP_bNB_ProBook 4520s_Y5336AN_0U_Q2CE11513X6_E618347-A44_4A_I1411_SHP_V57.34_68AZZ F.0F_T110218_WU48-0_L40C_M3952_J320_7Intel_8655_92.67_#101205_N18143090_(XX927EA#ABF)_XMOBILE_CN10_Z_2_G100268E4</MarkerFile>
  <SystemManufacturer>Hewlett-Packard</SystemManufacturer>
  <SystemProductName>HP ProBook 4520s</SystemProductName>
  <BIOSVersion>68AZZ Ver. F.0F</BIOSVersion>
 </SystemInformation>
</WERReportMetadata>


je pense que c'est un problème de connexion a la base de données.
à noter que j'ai ajouter sqlserver avec les composant requise de l'installation

merci de m'aider
--

3 réponses

Messages postés
27581
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
17 février 2020
323
Bonjour,

Il semble que tu l'ais installé sur un windows 7 Pro 64bits... mais sous quel OS as tu développé ton programme ?
Le souci pourrait venir de là....


Messages postés
91
Date d'inscription
dimanche 12 août 2007
Statut
Membre
Dernière intervention
21 septembre 2014
1
Merci jordane45 pour la réponse,

effectivement, je l'ai installé sur un Windows 7, 64 bits et je l'ai développé sur un windows 8, 64 bits aussi.

--
Messages postés
91
Date d'inscription
dimanche 12 août 2007
Statut
Membre
Dernière intervention
21 septembre 2014
1
j'ai essayé de recompiler l'application sur un autre pc, il m'affiche le message d'erreur suivant :

Impossible d'ouvrir la base de données "regimedb" demandée par la connexion. La connexion a échoué.
Échec de l'ouverture de session de l'utilisateur 'user1'.

donc c'est un problème de connexion à la base de données

--