Connexion postgresql avec windev17

makramsakhri
Messages postés
2
Date d'inscription
mardi 6 avril 2010
Statut
Membre
Dernière intervention
14 septembre 2014
- Modifié par Whismeril le 14/09/2014 à 08:49
Whismeril
Messages postés
17804
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
25 septembre 2022
- 14 sept. 2014 à 08:50
Bonjour,
je suis désolée de vous déranger, J'ai besoin de votre assistance
j'ai connecté à groupware par une code qui j'ai mettre dans "le code du projet" (les tables est crée automatiquement dans schéma public postgresql) mais il y à un problème présente lorsque j'exécute mon projet,
cette erreur est déclenche lors j'ai clique sur bouton (historique des connexions) du l'interface de groupware.
voilà le code de connexion à groupware :

//////////////////////////////////////////////////
sValeur est une chaîne = "localhost"

// Modifie la valeur 'ADRESSE'
INIEcrit("RESEAU", "ADRESSE", sValeur, "C:\Mes Projets\GS-hamdi\config.ini")

SI ErreurDétectée ALORS
    Erreur()
FIN
//connexion à la base
sAdresseip est une chaîne
/////////////////////////////////////////////
// je lis l'adresse reseau dans mon fichier init
sAdresseip = INILit("RESEAU","ADRESSE", "", fRepEnCours()+"\config.ini")
// je gere le groupeware avec .
// cette première partie permet de génerer les tables du groupeware dans ma base de données. Il en fait également une gestion automatique.
// gpwCx : c'est le nom que je donne à ma connexion pour les table de groupeware .
// gpwCx : c'est pour dire : "groupeware Connection"
SI gpwOuvreConnexion("gpwCx","postgres","sakhri",sAdresseip,"DataBaseHamdi",hAccèsNatifPostgreSQL) = Faux ALORS
    Erreur(ErreurInfo())
SINON
// Les fichiers du Groupware utilisateur sont automatiquement créés
// si l'utilisateur a les droits sur postgresql.
nRest est un entier = gpwOuvre()
// si le login a échoué
SI nRest <> gpwOk ALORS
    SELON nRest
        CAS gpwErreur : Erreur("Erreur à l'initialisation du groupware.", ErreurInfo())
        CAS gpwUtilisateurInconnu : Erreur("Utilisateur inconnu.")
        CAS gpwMotPasseInvalide : Erreur("Mot de passe invalide.")
    FIN
    SINON
        // cnxgres : connexion que je peut utiliser dans mon projet .,cnxgres : juste pour dire : "ma connexion à postgresql"
 SI PAS HDécritConnexion("cnxgres","postgres","sakhri",sAdresseip,"DataBaseHamdi",hAccèsNatifPostgreSQL,hOLectureEcriture) ALORS
            Info("Connexion echouée")
        SINON
            HChangeConnexion("*","cnxgres")
            HOuvre("*")

        FIN
    FIN
FIN
///////////////////////////////////////////////////////////////////////////

Les interfaces :

/////////////////////////////////////////////////////////////////////
voilà erreur:

Code situé derrière le bouton historique de connexion :
Ouvre("GPWHistoriqueConnexion")

et aussi la fenêtre GPWHistoriqueConnexion est initialise par le procédure
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
PROCEDURE Initialisation()

// par défaut on filtre sur le projt en cours d'exécution
Application=ProjetInfo(piNomEXE)
// si c'est un exécutable qui est lancé
SI Application<>"" ALORS
sNomCourt est une chaîne=fExtraitChemin(Application,fFichier)
Application=sNomCourt
// si c'est un GO sous l'éditeur
SINON
Application=ProjetInfo()
FIN
// exécute le code de clic du bouton Filtre
ExécuteTraitement(Filtre,trtClic)
// exécution de la requête
sSQL est une chaîne=[
SELECT COUNT(*) AS NbConnexion, Left(GPWHISTORIQUECONNEXION.HeureConnexion,2) AS HeureJournee
FROM GPWHISTORIQUECONNEXION
WHERE GPWHISTORIQUECONNEXION.DateConnexion='%1'
GROUP BY Left(GPWHISTORIQUECONNEXION.HeureConnexion,2)
ORDER BY Left(GPWHISTORIQUECONNEXION.HeureConnexion,2)
]
sSQL=ChaîneConstruit(sSQL,DateDuJour())
SI PAS HExécuteRequêteSQL(gReqConnexion,sSQL) ALORS
Erreur(HErreurInfo())
SINON
// affichage du résultat de la requête dans le graphe
grSourceSérie(GRF_Connexion,1,grRubrique,gReqConnexion,"NbConnexion")
grSourceEtiquetteCatégorie(GRF_Connexion,grRubrique,gReqConnexion,"HeureJournee")
grDessine(GRF_Connexion)
FIN
/////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
Vraiment je suis bloque à cet erreur (merci)

2 réponses

Whismeril
Messages postés
17804
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
25 septembre 2022
616
14 sept. 2014 à 08:48
Bonjour, message modifié par l'ajout des balises de code.
Voir ici comment bien utiliser la coloration syntaxique.

A noter que Windev n'est pas prévu dans la liste des langages, j'ai donc laissé la coloration par défaut, ce qui explique pourquoi le rend n'est pas le même pour l'un et l'autre.
0
Whismeril
Messages postés
17804
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
25 septembre 2022
616
14 sept. 2014 à 08:50
J'ai forcé le premier en java, pour que les commentaires apparaissent en vert
0