Programme qui se lance au demmarage mais sans effet

Signaler
Messages postés
43
Date d'inscription
vendredi 22 avril 2011
Statut
Membre
Dernière intervention
2 juin 2014
-
Messages postés
43
Date d'inscription
vendredi 22 avril 2011
Statut
Membre
Dernière intervention
2 juin 2014
-
bonjour tout le monde
j'ai un problème qui ma vraiment coincer de puis une semaine,
ou j'ai développez un petit programme qui fait des capture d'écran et sauvegarde les capture dans un dossier, mais le problème ces que quand je lance moi le programme (double clique sur le programme)
il fait les capture et les sauvegardé dans le dossier prévu, mais quand je mais
le programme au démarrage de Windows
(pour qu'il se lance au démarrage dans la clé
"HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run") il se lance, je le trouve dans le gestionnaire des tache mais il ne fait pas les capture
si qq1 a une solution a ce problème je le remercie d'avnce
MERCI

6 réponses

Messages postés
15127
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
22 novembre 2020
462
Bonsoir, tu as essayé dans le dossier "Démarrage" du menu démarré?

Messages postés
43
Date d'inscription
vendredi 22 avril 2011
Statut
Membre
Dernière intervention
2 juin 2014

Bonsoir, désoler pour le retard, vous voulez dire msconfig ?
le problème n'est pas au démarrage car le programme démarre avec Windows, mais ne fait pas son travail (les captures)
Messages postés
43
Date d'inscription
vendredi 22 avril 2011
Statut
Membre
Dernière intervention
2 juin 2014

bon, j'ai essayé avec le dossier Démarrage mais le problème reste toujours
Messages postés
43
Date d'inscription
vendredi 22 avril 2011
Statut
Membre
Dernière intervention
2 juin 2014

qq1 a de réponse a ce problème ?
Messages postés
15127
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
22 novembre 2020
462
Sans plus d'éléments ça va être dur.
Messages postés
74
Date d'inscription
samedi 8 décembre 2012
Statut
Membre
Dernière intervention
14 juin 2014
17
Le dossier de destination pour tes screenshots, dans ton programme, tu l'as écris en absolu ou relatif ? (C:/User/amazber/path/screenshots ou [/]path/screenshots ?)

Si il est relatif, en effet ton programme ne saura pas sauvegarder les images dans le dossier ! (problème de droits)

Je te conseille de rajouter dans ton programme un petit debugger (style des messages qui s'affiche à chaque action effectuée par ton programme, ainsi tu trouveras l'erreur aisément !)

Cordialement,
YepoMax.
Messages postés
43
Date d'inscription
vendredi 22 avril 2011
Statut
Membre
Dernière intervention
2 juin 2014

MERCI YepoMax
je vais prendre tes conseilles en considération