Ploblème caractères spéciaux

Messages postés
48
Date d'inscription
lundi 21 octobre 2013
Statut
Membre
Dernière intervention
29 mars 2014
- - Dernière réponse : mpmp93
Messages postés
6709
Date d'inscription
mercredi 13 avril 2011
Statut
Membre
Dernière intervention
28 septembre 2015
- 23 janv. 2014 à 22:02
Bonjour,

J' arrive même pas à gérer jusqu'à maintenant les caractères spéciaux.
Comment les gérer dans sql? Quant on insert les valeurs dans la base de données?

Exemple:
$dir=$_POST['direction']; // Direction des Systèmes d'information
INSERT INTO table Values('','".$dir."');

Ici, quand j'enregistre dans la base de données, le "è" du système et " l'apostrophe(') " du d'information sont enregistrés mal dans la base!

J'aimerai bien voir les informations correctes dans la base de données

Merci d'avance pour votre réponse
Urgent,
Afficher la suite 

2 réponses

Messages postés
1313
Date d'inscription
jeudi 16 juillet 2009
Statut
Membre
Dernière intervention
20 juin 2014
6
0
Merci
Hello,

Vérifie que ta base de données a été créée avec un encodage en UTF8, en l'occurrence soit utf8_unicode_ci soit utf8_general_ci.

Ensuite vérifie que dans tes scripts la connexion à ta base spécifie bien l'encodage des caractères en UTF8.

A+
Commenter la réponse de BBFUNK01
Messages postés
48
Date d'inscription
lundi 21 octobre 2013
Statut
Membre
Dernière intervention
29 mars 2014
1
0
Merci
tu peux essayer d'expliquer plus précisément la réponse?
Merci
mpmp93
Messages postés
6709
Date d'inscription
mercredi 13 avril 2011
Statut
Membre
Dernière intervention
28 septembre 2015
4 -
Commenter la réponse de vandouzen007