Probleme ACCESS et Champ OLE [Résolu]

Signaler
Messages postés
22
Date d'inscription
jeudi 3 novembre 2005
Statut
Membre
Dernière intervention
27 août 2007
-
cs_rt15
Messages postés
3874
Date d'inscription
mardi 8 mars 2005
Statut
Modérateur
Dernière intervention
7 novembre 2014
-
bonjour,

j'ai besoin de visualiser le contenu d'un champ d'une table ACCESS. Le champ est de type Objet/OLE et quand je visualise la table en mode feuille de données il y a "Données binaires" d'afficher. Quand je double clique dessus j'ai un message d'erreur " Un problème est survenu durant la communication Entre Microsoft Access et le serveur OLE ou le controle Active X .."

Je voudrais absolument récupérer ces données , ce peut-être une image ou du text ?

Pouvez-vous m'aider car je suis vraiment bloqué ?

Merci par avance.

rubix,

5 réponses

Messages postés
3874
Date d'inscription
mardi 8 mars 2005
Statut
Modérateur
Dernière intervention
7 novembre 2014
10
Erf.

A tout hasard, tu peux essayer de reposer ta question sur vbfrance dans une rubrique qui va bien. Ils sont plus habitués à l'OLE.
Messages postés
3874
Date d'inscription
mardi 8 mars 2005
Statut
Modérateur
Dernière intervention
7 novembre 2014
10
Salut,

Apparament, dans ta base, tu as des objets. Ce n'est ni une image ni du texte, c'est un objet COM.
C'est un peu comme un objet en C++, mais il respectent un certains nombre de critère : ils implémentent des interfaces.

Je sais pas ce que tu vas bien pouvoir faire avec...

Si c'est des contrôles ActiveX (Un sous ensemble des objets COM, implémentant plus d'interfaces), tu dois pouvoir les afficher, par exemple sous Internet Explorer.

Bon courage.
Messages postés
22
Date d'inscription
jeudi 3 novembre 2005
Statut
Membre
Dernière intervention
27 août 2007

Effectivement ça doit être ça,  y'a de l'Active X la dedans .... Peut tu me dire la manipulation à faire pour exporter ma table et la visualiser sous internet explorer ?

Merci,

rubix.
Messages postés
3874
Date d'inscription
mardi 8 mars 2005
Statut
Modérateur
Dernière intervention
7 novembre 2014
10
Erf, tu es pas le premier à souffrir sur ce problème.

Si on tape par exemple "retrieve OLE object access", on tombe sur pas mal de gens qui ont eu le même problème que toi, et pas des masses de solution...

http://support.microsoft.com:80/support/kb/articles/q175/2/61.asp&NoWebContent=1' target='_blank'>Si c'est des images, tu peux regarder cette article.
Messages postés
22
Date d'inscription
jeudi 3 novembre 2005
Statut
Membre
Dernière intervention
27 août 2007

Merci pour le lien, mais je suis certain que ce n'est plus une image, donc je suis bloqué :-)
c'est un genre d'interface graphique avec différents éléments dedans (TextBox, Shape , Line etc ...) donc je pense que le liens ne me servira pas à grand chose puisque c'est juste pour visualiser des images .
Merci, Quand même,

rubix