Erreur de syntaxe dans l'instruction INSERT INTO. [Résolu]

sunruyz21 13 Messages postés lundi 30 avril 2007Date d'inscription 2 juin 2008 Dernière intervention - 20 mai 2008 à 11:54 - Dernière réponse : smarwi 4 Messages postés lundi 21 mai 2007Date d'inscription 10 juin 2008 Dernière intervention
- 10 juin 2008 à 14:23
salut a tous
j'ai un probleme Erreur de syntaxe dans l'instruction INSERT INTO. et ma code est:
<%
SN_BASE = "DBQ=" & Server.Mappath("ma database.mdb") & ";Driver={Microsoft Access Driver (*.mdb)};DriverId=25"
DSN_BASE="Data Source=" & Server.Mappath("path.mdb") & ";Provider=Microsoft.Jet.OLEDB.4.0;"
Set Connection = Server.CreateObject("ADODB.Connection")
Connection.Open DSN_BASE

'on recupere le numéro de la reponse
'-----------------------------------
vnom=request.form("nom")
vpre=request.form("prenom")
vdn=request.form("date_naissance")
vadresse=request.form("adresse")
vtel=request.form("tel")
vfax=request.form("fax")
vemail=request.form("email")
vsex=request.form("sexe")
vrs=request.form("raison_social")
vnom_c=request.form("nom_contact")
vgc=request.form("gc")
vpass=request.form("pass")
vn=request.form("numero")
vcom=request.form("complement")
vville=request.form("ville")
vcp=request.form("code_p")

'set RsAuteur = server.CreateObject("ADODB.Recordset")
SQL = "Insert into revendeur (nom,prenom,date_naissance,sexe,raison_social,nom_contact,gc,email,pass,adresse,n,complement,ville,code_p,tel,fax) VALUES ('" & vnom & "','" & vpre & "'," & vdn & ",'" & vsex & "','" & vrs & "','" & vnom_c & "','" & vgc & "','" & vemail & "','" & vpass & "','" & vadresse & "','" & vn& "','" & vcom & "','" & vville & "','" & vcp & "','" & vtel & "','" & vfax & "');"
response.Write(sql)
connection.Execute(SQL)
'RsAuteur.Open sql,connection,adOpenDynamic

connection.Close
set connection = nothing
%>
qlq 1 peut m'aider please
merci en avance
Afficher la suite 

2 réponses

Répondre au sujet
sunruyz21 13 Messages postés lundi 30 avril 2007Date d'inscription 2 juin 2008 Dernière intervention - 2 juin 2008 à 13:46
+3
Utile
j'ai trouvé l'erreur et j'ai resourde mon probleme  merci a tous
Cette réponse vous a-t-elle aidé ?  
Commenter la réponse de sunruyz21
smarwi 4 Messages postés lundi 21 mai 2007Date d'inscription 10 juin 2008 Dernière intervention - 10 juin 2008 à 14:23
0
Utile
bonjour,
j'ai presque le meme probleme que toi mais en C#. comment tu a resolu ton problème?
Merci d'avance

Rien ne sert courir, il faut  partir à point
Commenter la réponse de smarwi

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.